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Introduction to TTR500 series VNAs

Introduction to TTR500 series VNAs
The TTR500 series (503A/506A) Vector Network Analyzer (VNA) is a portable, 2–port network
analyzer. The VNA operates over a frequency range of 100 kHz-3 GHz (TTR503A) and 100 kHz-6 GHz
(TTR506A). You use the VNA to measure the network parameters of electrical networks to characterize
high-frequency passive components and active devices (in their linear mode of operation). The VNA
separates signal sourcing and detection from processing measurements, which you perform using the
VectorVu-PC vector network analysis software. VectorVu-PC software is available in the TTR500 series
instrument. When you connect the VNA to a PC for the first time, VectorVu-PC installs on the computer.
You use an AC adapter to power the analyzer. The VNA connects to a Windows PC through a standard
USB 2.0 cable. You can also sync the VNA with other instruments using an external trigger.

See Also
Install VectorVu-PC
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TTR500 series product documentation

TTR500 series product documentation
In addition to the compiled help file, these manuals are available in the TTR500 series product
documentation set:
Quick Start Guide containing installation, safety, and compliance instructions
Programmer’s reference
Specifications and performance verification
Security and declassification
You can download all of these manuals at www.tek.com/downloads.
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Understand the VNA

Understand the VNA
You use the VNA to make network parameter measurements. You analyze these measurements using
VectorVu-PC software on a Windows machine. VectorVu-PC is preloaded on the instrument. When you
first connect the VNA to a Windows PC, VectorVu-PC installs on the machine. Use VectorVu-PC to process
measurement data captured using the TTR500 series VNAs or view data obtained using other VNAs.
These topics describe the hardware and software interfaces of the TTR500 series VNA.
Topic
Hardware

Related information
The front panel
The rear panel

Requirements

System requirements
Power source requirements

Software installation

Install VectorVu-PC

Software

VectorVu-PC vector analysis software
Screen area
Menu bar
Data entry bar
Soft key panel
Instrument status bar
Channel status bar
Graph area

xxx

The front panel
The front panel of the TTR503A and TTR506A VNAs has these components:
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The front panel

No.

Component

Description

1

RF Port 1

N-type 50 Ω female test port for device-under-test (DUT)
connection. Use either RF port for stimulus source or
response receiver.
Maximum operational RF input level 10 dBm (100 kHz—6
GHz)

2

LO A

SMA 50 Ω female port 10 dBm, 0 VDC (reserved for
future use)

3

LED Indicator

Indicates whether the VNA is powered and disconnected
(red) or connected (green).

4

LO B

SMA 50 Ω female port 10 dBm, 0 VDC (reserved for
future use)

5

RF Port 2

N-type 50 Ω female test port for device-under-test (DUT)
connection. Use either RF port for stimulus source or
response receiver.
Maximum operational RF input level 10 dBm (100 kHz—6
GHz)

xxx
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The rear panel

The rear panel
The rear panel of the TTR503A and TTR506A VNAs has these components:

No.

Component

Description

1

Bias 2

Provides bias input for RF port 2

2

Aux Sync

50 Ω female BNC connector (reserved for future use)

3

Trigger In

50 Ω female BNC connector to connect an external device
to provide a trigger input

4

USB 2.0

Connect USB 2.0 cable to Windows PC

5

4.75 V– 5.25 VDC

DC input to power the instrument

6

Ref In

50 Ω female BNC high impedance connector to provide
optional 10 MHz reference input

7

Ref Out

50 Ω female BNC connector to provide 10 MHz reference
output

8

Bias 1

Provides bias input for RF port 1

xxx

System requirements
Each TTR500 series VNA instrument connects to a Windows PC machine and requires 1 USB port.
The VectorVu-PC software operates on Windows 7/8/10 operating systems.

Power source specifications
Characteristic

Description

AC input voltage

100 VAC – 240 VAC
47 Hz – 63 Hz

DC power output

4.75 V – 5.25 V

VNA power consumption

<16 W

xxx
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Install VectorVu-PC
From the VNA
1. Connect the VNA to a power source using the AC adapter.
2. Use the USB 2.0 cable to connect the VNA to your Windows PC.
3. In Windows, navigate to the TTR500 drive and run setup.exe. The installation wizard opens.
4. Follow the steps in the installation wizard to install VectorVu-PC and Tektronix TTR500 family driver
files. Optionally, you can also install the TekVISA program to communicate with VectorVu-PC
through a programmatic interface.
NOTE. If you need to perform power calibration to measure active devices, install Tektronix Power
Meter Apps V4_5 to use the Tektronix PSM Series Power Meters. For other supported power meters and
power sensors, see Power calibration requirements.

From the web
You can download VectorVu-PC from the Tektronix website at www.tek.com/downloads.

Set up TekVISA
When you install VectorVu-PC, you can also choose to install the TekVISA application package. TekVISA
is the Tektronix implementation of VISA (Virtual Instrument Software Architecture), an industry-standard
communication protocol.
When installed on a PC, TekVISA provides communication with instruments that are connected to the PC
using the OpenChoice Instrument Manager application. You can also communicate with the VNA through
a programmatic interface using the OpenChoice Talker Listener program in the TekVISA package.
NOTE. If you have a previous version of TekVISA already installed on your system, this may not be
compatible with the TTR500 series VNA. To ensure proper functionality, install TekVISA through the
VectorVu-PC installation wizard.

Programmatic operation
Once you have installed VectorVu-PC and TekVISA programs using the installation wizard,
1. Open the OpenChoice Instrument Manager application.
2. Click Identify. The Instrument Manager recognizes the TTR500 VNA. When you connect multiple
VNAs to your computer, Instrument Manager detects all connected instruments.

8
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VectorVu-PC vector analysis software

3. Open the OpenChoice Talker Listener application. The VNA should appear in the Instrument window.
4. Enter *IDN? in the Command text box and click Query. The application identifies the VNA in the
window below.
You can now send SCPI commands to communicate with the VNA. For more information on compatible
SCPI commands and their syntaxes, refer to the TTR500 Programmers Manual available at www.tek.com.

Remote connection
You can use OpenChoice Talker Listener to login remotely from another machine and issue SCPI
commands to the VNA. Use the Windows Remote Desktop option for this purpose.

VectorVu-PC vector analysis software
When you power the VNA and connect it to a Windows PC for the first time, the instrument prompts you
to install VectorVu-PC – the vector network analysis software that you use to process measurements.
Use VectorVu-PC to make network parameter measurements of passive components and active devices.
You can also use VectorVu-PC to view measurement data recorded in touchstone files (S1P, S2P formats)
using other VNAs as well as data generated from circuit simulation software.
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Screen area

Screen area
The primary components of the VectorVu-PC interface are:

No.

Component

1

Menu bar

2

Data entry bar

3

Soft key panel

4

Instrument status bar

5

Channel status bar

6

Graph area

xxx

Menu bar
The menu bar has several groups of options available as pull-down menus. Each of the option groups
has a corresponding set of soft keys in the soft key panel. You can access all of these menus using a
mouse or touch screen.

10
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Menu bar

In the Response option group:
Action

Soft key

Show/hide the menu bar

Display > Menu Bar > Display Menu Bar

Set the font size for the menu bar

Display > Menu Bar > Bar Font

xxx
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Data entry bar

See Also
Data entry bar

Data entry bar
The data entry bar displays values of parameters associated with the selected menu (or ‘active menu’).
or press the enter key to apply
Click on a parameter in the data entry bar to change its value. Click
the change. You also use the data entry bar when a setting in the active menu or submenu requires a data
entry for a parameter.

See Also
Soft key panel

Soft key panel
The soft key panel contains option groups with different operations. Each of these option groups have
pull-down menus in the menu bar. Some of the operations in an option group contain submenus for
selections and data entry. You can access all of these menus using a mouse or touch screen.
Option Group

Description

Channel/Trace

Select the number and layout of channels and traces to display.

Markers/Analysis

Set markers, perform search analysis, and adjust graph parameters using markers.

Stimulus

Set frequency range, sweep, power, and trigger parameters.

Response

Measure system response for the stimulus through network parameters, calibrate the DUT,
and set display options.

System

Select language options, manage device connections, save and recall states, or restore
factory preset.

xxx
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Instrument status bar

When you select an operation in an option group, any submenu it contains becomes the active menu. If
there are no submenus, the entire option group is displayed.
For example, if you want to set up a sweep operation, select the Sweep Setup operation in the Stimulus
option group. The Sweep Setup submenu becomes the active menu.

See Also
Instrument status bar

Instrument status bar
The instrument status bar displays settings and usage information about your TTR500 VNA. Use the
corresponding soft key paths to change these settings.
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13

Get started with the VNA

No.

Setting

1

Error/warning messages

2

Instrument status bar

Indication
-

Default

Soft key path
-

Active port

Active port that is currently
transmitting.

Port 1 active (solid
circle)

No soft key. Switch
device or cable
connection to port
2.

3

Bias tee setup

Display indicates that internal
bias tee is enabled.

Off (does not
display)

System > More >
Bias tee

4

Display update.

Enable/disable dynamic
updates to graph.

ON (Enable
dynamic update)

Display > Update

5

RF Out.

Enable/disable RF output.

ON (Enable RF
output)

6

Measurement status

Measurement initialized or in
progress.

In Progress

Stimulus > Sweep
Setup > Power
Menu > RF Out
-

7

Trigger source

Trigger source used:

Internal

Stimulus > Trigger
> More > Trigger
Source

Internal

System > More >
Reference Clock
Source

Not applicable

Internal
External
Manual
SCPI
8

Reference clock source

Clock source used:
Internal
External

14

TTR500 Series User Manual

Get started with the VNA

Channel status bar

No.

Setting

Indication

9

Temperature

Temperature setting of
TTR500 instrument

Default
Yellow when
starting VNA
or stabilizing
internal
temperature

Soft key path
-

Green when
VNA is
in normal
operation.
Red when
instrument is
overheated.
VectorVu-PC
switches to
offline mode.
10

Instrument Connection.

Information about
active connection to
VectorVu-PC—instrument
paired with an instance of the
program.

Green indicates
an active VNA
connection or
simulator (offline)
mode.

System > More >
Connections

xxx

NOTE. When you operate VectorVu-PC in simulator (offline) mode, the instrument status bar turns gray
with the exception of the Instrument Connection icon. Errors and warning messages are available
when using the simulator. All other settings apply only when VectorVu-PC has an active connection
with a TTR500 VNA.

See Also
Channel status bar

Channel status bar
The channel status bar displays these parameters about the channel.
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Graph area

No.

Parameter

Description

1

Channel number

Number of the current channel

2

Start (or Center) frequency

Start (or Center) frequency of sweep

3

IF Bandwidth

IF bandwidth for the frequency sweep

4

Stop (or Span) frequency

Stop (or Span) frequency of sweep

5

Averaging
status

Number of traces averaged / Total
number of traces to average

Averaging count (n) / Averaging factor (m) ratio
indicates averaging ON
No display indicates averaging OFF

6

Port extension
status

PExt indicates port extension
ZExt indicates impedance extension

Indicates whether port or impedance
extension is set

No display indicates no extension set
7

8

Power
calibration
status

PC indicates power calibration ON.

Error correction
status

Cor indicates error correction ON

No display indicates no power calibration data

Off indicates error correction turned OFF

Power calibration data for each
channel/test port. You can turn power
calibration ON/OFF independently for
any channel or test port.
Execution status of error correction on
the channel

! indicates error correction has different
parameters
* indicates error correction is interpolated
9

Channel
measurement
status

! indicates measurement in progress
# indicates invalid traces, if they have not been
updated to match a change in measurement
conditions

Updates status of traces on the
channel

No display indicates the measurement has not
been executed
xxx

See Also
Graph area

Graph area
The graph area displays trace measurements on the DUT. If a channel has multiple traces, in the default
setting, all traces of that channel appear on a single graph. You can display channels or traces individually
by selecting:
Channel / Trace > Channel > Channel Layout
Channel / Trace > Trace > Trace Layout

16
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Graph area

Display update
By default, the graph updates trace information dynamically when you perform measurements. For
improved speed of performance, you can turn off display update. Set or clear this feature in Response
> Display > Update.
The status of this feature is visible in the
icon in the instrument status bar. When you disable
display update, the data entry bar is not updated either.

Invert color
When you need to print an image of the graph area, invert the colors of the graph to reduce ink usage and
improve clarity on paper. Select this option in Response > Display > Invert Color.

TTR500 Series User Manual
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Set channels

Set channels
A channel is a specific setup or configuration of the VNA to make a measurement. Channels operate like
independent analyzers with these settings:
Stimulus signal settings (frequency range, sweep type, etc.)
IF bandwidth and averaging
Calibration
Up to 16 channels are available to make measurements under different stimulus conditions using the VNA.
Since all channels operate independent of each other, perform a calibration every time you set up a new
channel for better accuracy.
Each allocated channel contains one trace by default. Additionally, you can add up to 16 traces for
a channel.
NOTE. Set channels and traces before setting up measurement conditions since some measurement
parameters apply only to an active trace or channel.
To set channels,
1. Select Channel / Trace > Channel > Num Channels.
2. Select the required number of channels in the data entry bar.
When you recall an instrument state that was previously saved, configurations with fewer channels are
easier to load than configurations with a large number of channels. Therefore, states with 1 or 2 channels
load much faster than states with 13–16 channels.

Channel operations
When you select multiple channels, the default display shows the active channel only. The active channel
is the channel that is currently selected and whose settings can be changed. The active channel cannot
display measurements made on another channel.
Operation

Soft key path

Set number of channels to display

Channel / Trace > Channel > Num Channels

Assign additional channel to
display (up to 16 channels)

Channel / Trace > Channel > Allocate Channel

Set graph layout to display
assigned channels

Channel / Trace > Channel > Channel Layout

Maximize active channel

Channel / Trace > Channel > Max

Set the active channel

Channel / Trace > Channel > Active

TTR500 Series User Manual
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Set traces

Operation

Soft key path

Select the previous channel

Channel / Trace > Channel > Previous

Select the next channel

Channel / Trace > Channel > Next

xxx

You can assign the same channel across multiple display windows.
You can also use triggers to perform measurements on a channel without making it active.

See Also:
Set Trigger for Measurement

Set traces
The trace display sets the number of traces to be displayed in a single channel.
Operation

Soft key path

Set number of traces to display in
the active channel

Channel / Trace > Trace > Num Traces

Assign a trace to a particular
channel

Channel / Trace > Trace > Allocate Trace

Set graph layout to display
assigned traces

Channel / Trace > Trace > Trace Layout

Maximize a trace

Channel / Trace > Trace > Max

Move a trace (between windows of
the same channel only)

Drag and drop the trace.

Set the active trace

Channel / Trace > Trace > Active

Select the previous trace

Channel / Trace > Trace > Previous

Select the next trace

Channel / Trace > Trace > Next

xxx

Set graph display
Multiple channels
When you select multiple channels, each channel is assigned to a window. By default, you see the graph of
the active channel. When you use the Previous and Next soft keys, you can switch between channels
to see the traces they contain.
To view the graphs of multiple or all channels simultaneously, change the display configuration:

20
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Characteristic impedance (system Z0)

In Channel / Trace > Channel > Channel Layout.
In Channel / Trace > Window > Graph Layout > Channel Layout.

Multiple traces
When you select multiple traces for a channel, all viewable traces display on the active channel in different
colors. To view each trace in a separate window, change the display configuration in Channel / Trace >
Trace > Trace Layout.

Characteristic impedance (system Z0)
The characteristic impedance of a TTR500 series VNA is fixed at 50 Ω.

Set stimulus conditions
Use settings in the Stimulus option group to define these stimulus parameters to provide to the DUT.
Start frequency
Stop frequency
Center frequency
Span frequency
Sweep parameters
Trigger parameters

Stimulus operations
Sweep frequency
Setting

Options/Description

Soft key

Sweep range

Start/Stop define a sweep between
starting and stopping frequencies

Stimulus > Start

Center/Span define a sweep based
on a frequency span around a center
frequency

Stimulus > Center

Stimulus > Stop
Stimulus > Span

xxx
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Set stimulus conditions

Sweep setup
Setting

Options/Description

Soft key

Auto sweep time

VectorVu-PC automatically configures
sweep time setting.

Sweep Setup > Auto Sweep Time

Sweep time

Time taken to complete a sweep
(excludes sweep delay). Use sweep
time to control measurement time.

Sweep Setup > Sweep Time

Sweep delay

Delay before starting a sweep for a
measurement to account for device
stabilization

Sweep Setup > Sweep Delay

Points (Number of measurement
points)

Set 1–20,001 points to measure in a
single sweep for each channel

Sweep Setup > Points

Sweep type

Lin Freq – sweeps frequencies in
linear scale

Sweep Setup > Sweep Type

Log Freq – sweeps frequencies in
logarithmic scale
Measure in time-series (Time
sweep)

Time the sweep operation and display
measurement parameter versus time.

Set Span to 0.

Avoid spurious

Remove unwanted signals from
measurement display.

Sweep Setup > Avoid Spurious
See also Avoid spurious function.

Options/Description

Soft key

xxx

Power menu
Setting
Power level

Power Level – Sets power level of
the stimulus signal in dBm. Set the
same power level across all ports
when coupled

Sweep Setup > Power Menu >
Port Couple > Yes to couple ports.

Port Power – Set individual power
levels for every port in dBm when
ports are decoupled

Sweep Setup > Power Menu >
Port Couple > No to decouple
ports.

Sweep Setup > Power Menu >
Power Level

Sweep Setup > Power Menu >
Port Power
Slope

Compensate for power losses in cables
and test fixtures at high frequencies

Sweep Setup > Power Menu > Slope

Slope Value

Specify a value in dB/GHz for power
slope when slope is enabled.

Sweep Setup > Power Menu > Slope
Value

RF Out

Yes – Enable stimulus signal
output. In case of power trip, use
this setting to turn output back ON.

Sweep Setup > Power Menu > RF Out

No – Cannot perform
measurements.
xxx
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Trigger settings
Setting

Options/Description

Soft key

Trigger

Set source, delay, scope and other
trigger settings.

Stimulus > Trigger
See also Set trigger for measurement

xxx

Avoid spurious function
Spurious signals are unwanted signals that can generate in the VNA hardware due to interactions between
internal signals (such as processor clocks and local oscillators). These signals can appear as narrow
spikes (<10 kHz wide) at very low levels, near the receiver noise floor at IF bandwidths that are smaller
than 1 kHz.
The Avoid Spurious function (Stimulus > Sweep Setup) removes these responses from the measurement
display. This function is enabled by default.

Narrow band devices
When you measure very narrow band devices such as crystal filters, the passband of the filter can coincide
with the spurious response. In these cases, disable the spur avoidance function by toggling the Avoid
Spurious function off.

Set measurement parameters
You use the VNA to characterize a device or component using scattering parameters or S-parameters.
These sections discuss:
S-parameters
How to set S-parameter measurements
How to set absolute measurements

S-parameters
For a device network that operates at high frequencies (~ MHz/GHz), circuit dimensions are typically
much larger than the wavelength of the current. Characterizing such a device is easier using forward and
reverse traveling waves instead of voltage or current measurements. The ratios of these traveling waves
are represented by scattering parameters or S-parameters.
For a two-port network with characteristic impedances Z01 and Z02, the forward traveling wave enters the
network as a1 at port 1 and exits as b2 at port 2. The reverse wave enters the network as a2 at port 2
and exits as b1 at port 1.
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a1 and a2 then become the incident waves while b1 and b2 are the reflected waves.
S-parameters are the ratios of measurements of incident and reflected waves.

For example, S21 is the ratio of the signal exiting at port 2 to the signal entering at port 1. This table
describes the S-parameters for a 2–port network.
S-parameter

Ratio

Description

S11

Port 1 reflection coefficient

S21

Forward transmission coefficient (from port 1 to
port 2)

S12

Reverse transmission coefficient (from port 2 to
port 1)

S22

Port 2 reflection coefficient

xxx

Since S-parameters are vector quantities, they describe the magnitude and phase of the signal.

Set S-parameters
1. In the Response option group, click Measure.
2. Select the S-parameter you want to measure.

Set absolute measurements
Absolute measurements measure the absolute levels of signals at the input of the VNA receiver. While
S-parameters involve a relation between input signals of two receivers, absolute measurements apply
only to the input signal of one receiver. Therefore, absolute measurements are individual signals while
S-parameters are ratios of test and reference signals.
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Description

A1

Test signal at port 1 when stimulus is on port 1

A2

Test signal at port 2 when stimulus is on port 1

B1

Test signal at port 1 when stimulus is on port 2

B2

Test signal at port 2 when stimulus is on port 2

R11

Reference signal at port 1 when stimulus is on port 1
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Absolute measurement

Description

R12

Reference signal at port 1 when stimulus is on port 2

R21

Reference signal at port 2 when stimulus is on port 1

R22

Reference signal at port 2 when stimulus is on port 2

xxx

To make an absolute measurement, click Response > Measure > Absolute and select the absolute
measurement.

Set the bias tee
Measuring some active DUTs requires a DC voltage to be applied to the RF center conductor. You can
feed this DC voltage at the bias tee inputs on the rear panel of the TTR500 VNA. The VNA supplies the
DC voltage to the DUTs through the RF port via the inner conductor. This is very useful when measuring
applications where a DC signal has to be applied to the RF port of a DUT.

To use the internal bias tee,
1. Connect a power supply to the bias tee connectors in the rear panel for each port.
2. In System > More > Bias Tee, enable the bias tee function.
NOTE. Do not power the bias tee connectors during calibration to avoid damage to calibration standards.
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Select a data format
In the Response > Format, select a data format to display your measurement data. These formats are
available:
Rectangular format
Polar format
Smith chart format

Rectangular format
In the rectangular format, you plot the measured response values on the Y-axis against stimulus values
on the X-axis. Depending on the type of measured response value on the Y-axis, select from one of
these formats:
Format

Label

Data Type

Measurement
Unit

Log magnitude

Log Mag

Magnitude

dB

Phase

Phase (Deg)

Phase (degrees)

Degrees

Phase (Rad)

Phase (radians)

Radians

Group Delay

Time

Seconds

Expanded Phase

Phase (degrees/radians)

Degrees/Radians

Positive Phase

Phase (degrees/radians)

Degrees/Radians

Linear magnitude

Lin Mag

No dimension

Standing Wave Ratio

SWR

Magnitude
-

No dimension

xxx

Polar format
When you represent complex numbers in the polar format, the magnitude of the number is the displacement
from a reference point while the phase becomes the counter-clockwise angular displacement from a
reference direction. You indicate the frequency using markers since the polar format does not have a
frequency axis.
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Use the polar format to display these data groups:
Linear magnitude and phase
Logarithmic magnitude and phase
Real and imaginary parts

Smith chart format
The Smith chart maps reflection coefficients of measurement data from the DUT to normalized impedances.
You plot traces using the same information as in the polar format. Frequencies are indicated by markers.
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Use the Smith chart format to display these data groups:
Linear magnitude and phase
Logarithmic magnitude and phase
Real and imaginary parts
Resistance, reactance, and inductance or capacitance
Conductance, susceptance, and capacitance or inductance

Set the scale
The scale sets the axis of the display plot in order to zoom in to points of interest or view all trace
measurements for a channel simultaneously. To set the scale,
1. Set a reference position on the graph (Response > Scale > Reference Position).
2. Set the scale for your display:
Auto scale
Manual scale
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Auto scale
For a particular trace, select auto scale to make the display window adjust the scale automatically when
you resize it.
In the Response option group, select Scale > Auto Scale to scale all traces in the active channel.
Select the Auto Scale All option to scale traces in different channels.

Manual scale
You can make these scale adjustments manually. Set these parameters in Response > Scale.

Rectangular format

Setting

Description

Divisions

Sets the number of divisions on the Y-axis

Scale/Divisions (Scale/Div)

Sets the size of each division. Applies only to the active trace.

Reference Position

Sets the position of the reference line on the Y-axis. Applies only to the
active trace.

Reference Value

Sets the value of the reference line with respect to the Y-axis. Applies only to
the active trace.

xxx

Polar and Smith chart formats
In polar and smith charts, you adjust the scale by a displacement to the outermost circle. Specify this
using the Scale/Div value in Response > Scale.
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Set a reference line value
To set the measurement value at the reference position, click Response > Scale > Reference Value.
You can also move the reference line for an active channel to the marker response value. Select Response
> Scale > Marker → Reference.

Set window displays
Use these options to set or clear preferences for the window display.
Operation
Maximize a channel or trace

Soft key path
Channel / Trace > Channel > Max
Channel / Trace > Trace > Max

Display graticule label on
the vertical axis (rectangular
format only)

Response > Display > Labels > Graticule Label

Frequency information on
horizontal axis (rectangular
format only) and channel
status bar

Response > Display > Labels > Display Frequency

Edit channel title for active
channel

Response > Display > Labels > Edit Title Label

Display channel title for active
channel

Response > Display > Labels > Display Title Label

Invert the display color

Response > Display > Invert Color > Inverted sets the display against a white
background
Response > Display > Invert Color > Normal sets the display against a black
background

xxx
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What is calibration?
Before making measurements with a VNA, you calibrate the VNA to reduce errors that can affect
measurements. An understanding of measurement errors is useful before proceeding to calibrate a VNA
because not all errors can be minimized this way. Measurement errors mainly fall into one of these types:
Drift errors
Random errors
Systematic errors

Drift errors
Drift errors occur when the behavior of a test system changes after you calibrate it. Drift errors are
primarily caused by temperature variation and can be removed by additional calibration. The rate of drift
determines how frequently the test system needs additional calibrations. You can typically minimize drift
errors by constructing a test environment with stable ambient temperature. Although you can specify test
equipment to operate over a temperature range of 0 °C to +55 °C, for optimal performance, operate the
VNA at +25 °C ± 5 °C. You can improve measurement accuracy and reduce or eliminate the need for
periodic recalibration by minimizing drift errors.

Random errors
Random errors are unpredictable errors that occur in VNA measurements due to noise fluctuations, thermal
drifts, cable bends, changes in cable dimensions, connector repeatability and other factors. These errors
are usually non-repeatable. Some ways to remove random errors include careful handling of cables and
connectors after calibration, proper setting of the source power, and maintaining a constant ambient
temperature. These errors cannot be eliminated by calibrating a VNA.

Systematic errors
Systematic errors are more intrinsic to components and devices in the measurement system than drift
or random errors. Systematic errors occur due to manufacturing imperfections in components of the
measurement system. Since these errors occur every time you perform a measurement, a calibration
operation can help remove systematic errors from VNA measurements.

TTR500 Series User Manual

31

Calibration

Calibration workflow

Systematic errors in reflection measurements
Error

Description

Directivity

Besides the reflection signal, a small portion of the incident signal is received by the
test receiver due to leakage in the test coupler.

Source match

The reflection signal of the DUT reflects at the signal source and reenters the DUT.
The source match is determined by the quality of the source reference coupler and
any mismatches between the coupler and the test port output (or DUT input).

Frequency response reflection
tracking

Difference in frequency response between the test and reference receivers of a
stimulus port.

xxx

Systematic errors in transmission measurements
Error

Description

Isolation (or crosstalk)

Signals other than the test signal leak into the test receiver at the transmission port.

Load match

A portion of the incident signal is reflected off of port 2 and does not get measured
at the receiver at port 2. The load match is a measure of how the receiver port
impedance deviates from the reference impedance.

Frequency response transmission
tracking

Difference in frequency response between the test receiver of a response port and
the reference receiver of a stimulus port.

xxx

When you calibrate a VNA, you perform a mathematical correction to the measurement results. This
mathematical calibration is different from the instrument calibration of microwave devices. Mathematical
calibration or error correction is the computation of the correction you need to apply to all four
S-parameters of the test network at any frequency of interest. You compute this correction as an array of
coefficients by using the VNA to measure known electrical standards at a fixed measurement plane.

Calibration workflow
When you perform coaxial measurements, you typically use Short, Open, Load, and Thru (SOLT)
standards as loads connected to test ports. Using these known standards, you perform measurements to
gather data and compute error correction parameters. The calibration workflow involves these steps:
1. Select a suitable calibration kit that matches the connector type of the test port. The calibration kit
contains SOLT standards with known S-parameters and matched impedances.
2. Select the calibration method to apply, based on the accuracy required. The calibration method
determines the extent to which the error correction will be applied to the model.
3. Compare the S-parameter measurements obtained using the VNA with the known S-parameters of the
standard. Based on these measurements, the VNA determines the systematic error correction.
4. Apply the systematic error correction to measurements made on the DUT.
NOTE. You perform calibration on a single channel at a time since the operation relies on the stimulus
provided to the channel.
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The SOLT standards are accurate devices that you can use as standards to calibrate the VNA. The
collection of standards for a specific connector type and impedance forms a calibration kit. Every standard
in a calibration kit has a mathematical definition for its parameters. When you use a standard from a
calibration kit in a particular calibration method, you create a calibration standard class.
NOTE. Calibration standards of predefined kits have their classes specified. When you select a user-defined
standard, make sure you specify its subclass in the dialog box of the standard.

The calibration plane
The calibration reference plane is the imaginary plane orthogonal to the ports of the VNA at which the
measurement is observed. Any adapter or cable connected to a port of the VNA is considered to be a part
of the VNA and therefore included in the reference plane.
When the adapter is inside the calibration plane its systematic error effects are removed, as long as the
adapter is in the same location as the VNA during measurement.
When the adapter is outside the calibration plane, you can remove the systematic error effects of the adapter
from your measurements by using the S-parameters of the adapter (if they are known or can be measured).
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Term

Definition

Calibration

The process of measuring known electrical standards using the VNA to determine measurement
errors and correct them.

Calibration reference
plane

The imaginary plane orthogonal to the ports of the VNA at which you perform calibration.

Electrical standard

Physical devices with accurately known magnitude and phase responses that are used to calibrate
a VNA.
Eg: Open, short, load

Standard coefficients

The numerical characteristics of a standard, specified by the polynomial equation of the model
that represents the standard.
Eg: C0,C1,C2,C3 coefficients of the third degree polynomial equation that defines the capacitance
model for an Open standard.
C=(C0)+(C1F)+(C2F2)+(C3F3)
where:
C: Capacitance
F: Measurement frequency

Calibration method

The procedure by which you calibrate a VNA.
Eg: SOLT, TRL

Calibration kit

A collection of known electrical standards. A single calibration kit can support multiple calibration
methods.

Standard subclass

A particular collection of standards in a calibration kit.
Eg: a collection of male standards at port 1, SOLT standards from 2.5 GHz–3 GHz

xxx

Select a calibration kit
A calibration kit is a collection of known calibration standards. The S-parameters of these standards
are documented parameters that are available at the time you perform calibration. When you select a
calibration kit, make sure it matches the connector type of the test port.
The VNA is preloaded with several calibration kits. To select a calibration kit, in the Response option
group, click Cal > Cal Kit and choose from the list of preloaded kits.
If you want to select a different calibration kit, you modify an empty kit according to the standards required.

See Also:
Add/Modify a Calibration Kit
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Select a calibration method
You can perform these calibrations using the TTR500 series VNA. Select these methods in Response
> Cal.

Calibration Type
Response calibration
(Reflection)

Available
Standards
Short

Open

Response calibration
(Transmission)

Thru

Enhanced response 2–port
1–path SOLT

Short
Open
Load
Thru

Soft key

Errors
Corrected

Calibrate >
Response >
Short

Reflection
tracking

S11

Calibrate >
Response >
Open

Reflection
tracking

S11

Calibrate >
Response >
Thru

Transmission tracking

S12

Calibrate >
Enhanced
Response

Reflection
tracking

S11,
S21
(stimulus
on
port 1)

Transmission tracking
Directivity
Source
match
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Accuracy
Medium

S22
Medium

S22
Medium

S21

S12,
S22
(stimulus
on
port 2)
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Calibration Type
1–port SOL

Select a calibration method

Available
Standards
Short
Open

Soft key
Calibrate >
1–port SOL

Errors
Corrected
Reflection
tracking
Directivity

Load

Measurement Parameters
S11

Accuracy
High

S22

Source
match
2–port SOLT Full 2–port

Short
Open
Load
Thru

Calibrate >
2–port SOLT

Reflection
tracking
Transmission tracking

S11

High

S12
S21
S22

Directivity
Source
match
Load
match
Isolation
xxx
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Calibrate the VNA
The next few sections describe procedures for every type of calibration you can perform using the VNA.
You can select the calibration method in Response > Cal > Calibrate.
Before you perform a calibration, make sure you:
Select an active channel for the calibration.
Set parameters for the active channel.
Select an appropriate calibration kit for the procedure.
Do not have power supplies connected to the bias tee connectors.

Isolation calibration
The isolation procedure corrects a calibration for crosstalk–the signal leakage between test ports when no
device is present.
When you perform an unguided 2-port calibration, you have the option of omitting the isolation portion of
the calibration. The uncorrected isolation between the test ports of the analyzer is exceptional (typically
>100 dB). Therefore, you should only perform the isolation portion of a 2-port calibration when you
require isolation that is better than 100 dB.
Perform an isolation calibration when you are testing a device with high loss, such as some filter stop
bands or a switch in the open position. The isolation calibration can add noise to the error model when
the measurement is very close to the noise floor of the analyzer. To improve measurement accuracy,
set a narrow IF Bandwidth.

Response calibration (Short/Open) - Reflection Test
1–port calibration
Connect an Open or Short standard to a test port of the VNA to perform reflection test.
Calibration eliminates the reflection tracking error from the network.
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Response calibration (Thru) - Transmission Test

Procedure
For the appropriate standard (short or open) that you want to calibrate,
1. In the Response > Cal > Calibrate menu, select Response calibration.
2. Select the appropriate soft key for the standard—Open or Short.
3. Select the test port to calibrate the standard. The dialog box for the port opens.
4. Connect the appropriate standard from the calibration kit to the test port of the VNA. Make sure
you select the right gender.
5. In the dialog box of the port, click the appropriate standard button. The VNA records a calibration
measurement. When the measurement is complete, a check mark appears next to the standard button
in the port dialog box.
6. Click Apply to save the calibration data. The VNA calculates and saves calibration coefficients.
The error correction function is also enabled.
NOTE. If you need to repeat a portion of a calibration procedure for a standard, use the overwrite feature
to override the information recorded by the VNA for the standard. For more information, see Partial
overwrite.

Response calibration (Thru) - Transmission Test
2–port calibration
Connect a Thru standard between the test ports of the VNA to perform transmission test.
Calibration eliminates the frequency response transmission tracking error from the network.
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Response calibration (Thru) - Transmission Test
Isolation calibration (optional) using Load eliminates isolation error.

Procedure
1. In the Response > Cal > Calibrate > Response menu, select the Thru calibration.
2. Select a Thru calibration option:
When the stimulus is at port 2 and you measure the response at port 1, you measure the S12 parameter.
When the stimulus is at port 1 and you measure the response at port 2, you measure the S21 parameter.
3. Connect the Thru standard from the calibration kit to the test ports of the VNA.
4. Click the Thru standard button in the dialog box of the test port. The VNA records a trace
measurement.
When the calibration measurement is complete, a check mark appears next to the Thru button in the
port dialog box.
5. For an optional isolation calibration, connect the Load standard to each of the test ports. Click
Isolation in the dialog box to make the calibration measurement.

TTR500 Series User Manual

39

Calibration

2-port 1-path SOLT (Enhanced Response) calibration

6. Click Apply to save the calibration data. The VNA creates and saves calibration coefficients. The
error correction function is also enabled.

2-port 1-path SOLT (Enhanced Response) calibration
2–port calibration
Connect Open, Short, or Load standards to stimulus port or connect Thru standard between stimulus
and response ports.
For isolation calibration, use Load on ports 1 and 2.
Calibration eliminates directivity error, reflection tracking, source match error, transmission tracking
error and crosstalk (isolation measurement) from the network.
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2-port 1-path SOLT (Enhanced Response) calibration

Procedure
1. Click Response > Cal > Calibrate and open the Enhanced Response menu.
2. Select a measurement. The dialog box for the measurement opens.
When the stimulus is at port 1 and you measure the response at port 2, you measure the S21 parameter.
When the stimulus is at port 2 and you measure the response at port 1, you measure the S12 parameter.
3. Connect the Open standard from the calibration kit to the stimulus port of the VNA.
4. Click the Open standard button in the dialog box. The VNA records a calibration measurement.
When the measurement is complete, a check mark appears next to the Open standard button in the
port dialog box.
5. Repeat steps 3 and 4 for the Short, Load, and Thru standards. For the Thru standard measurement,
connect the standard between the stimulus and response ports.
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1-port SOL calibration (Reflection Test)

6. For an isolation calibration, connect the Load standard to each of the ports. Click Isolation in the
dialog box to make the measurement.
7. After completing all measurements, click Apply to save the calibration data. The VNA creates and
saves calibration coefficients. The error correction function is also enabled.

1-port SOL calibration (Reflection Test)
1–port calibration
Connect Open, Short, and Load standards to test port.
Calibration eliminates errors due to directivity, reflection tracking and source match.

Procedure
1. Click Response > Cal > Calibrate and open the 1–port SOL menu.
2. Select the test port where you perform the 1–port SOL calibration. The dialog box for the test port
opens.
3. Connect the Open standard from the calibration kit to the test port of the VNA.
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NOTE. You can measure the Open, Short, and Load standards in any order.
4. Click the Open standard button in the dialog box of the stimulus port. The VNA records a calibration
measurement.
When the measurement is complete, a check mark appears next to the Open standard button in the
port dialog box.
5. Repeat steps 3 and 4 for the Short and Load standards.
6. Click Apply to save the calibration data. The VNA calculates and saves calibration coefficients.
The error correction function is also enabled.

2-port 2-path SOLT (Full Two Port) calibration
2–port 2–path calibration
Connect Open, Short, or Load standards to two test ports.
Connect Thru standard between the two VNA ports. Measure both transmission and reflection in
both directions.
Measure S11, S12, S21, S22 parameters
Calibration eliminates frequency response reflectivity tracking error, directivity, source match error,
load match error, transmission tracking and crosstalk (isolation measurement).
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Apply error correction

Procedure
1. Click Response > Cal > Calibrate and open the 2–port SOLT dialog box.
2. Connect Short, Open and Load standards from the calibration kit to Port 1 and record their
measurements using the corresponding soft keys in the 2–port SOLT dialog box.
3. Repeat step 2 to record Short, Open, and Load standard measurements for Port 2.
4. Connect the Thru standard between port 1 and port 2.
5. Click Thru in the SOLT dialog box to record the calibration measurement.
6. For an isolation calibration, connect Load standards to both test ports. Click Isolation to make the
measurement.
7. Click Apply to save the calibration data. The VNA creates and saves calibration coefficients. The
error correction function is also enabled.

Apply error correction
When you perform a calibration, the VNA enables the error correction function at the time you
save calibration data. This function applies an error correction (based on the calibration) to future
measurements. You apply the error correction to a channel (and consequently to all the traces it contains).

Enable error correction
To enable/disable the error correction function, in Response > Cal, click the Correction soft key. You
can see the status of the error correction function:
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Apply port extensions
In the data entry bar after you click Response > Cal.
In the channel status bar.

This table lists the settings for the error correction function:
Status

Description

No Data

No error correction data exists. Calibrate the VNA to obtain an error correction.

Cor

Error correction function is on.

!

Parameters do not match.

*

Error correction is interpolated

xxx

NOTE. You must have calibration data to enable the error correction function.

Distinction from factory error correction function
The error correction function described here is different from the factory error correction in the VNA. The
factory error correction automatically applies to all measurements. The factory correction is useful when
performing measurements without calibrating the instrument first. Proper calibration of the instrument
eliminates the need for the factory error correction.
The error correction function is more specific to the active measurement performed with the VNA.

See Also:
Disable factory error correction

Apply port extensions
When you use fixtures to connect the VNA to the DUT, these fixtures can also contribute to measurement
errors. To account for the delay of the test fixture, you can move the calibration reference plane. The new
calibration plane then exists at the terminals of the DUT. You do this by applying port extensions.
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Port extensions are useful when:
You cannot connect a DUT directly to the test ports at the calibration plane. You can use port
extensions to calibrate the VNA at a convenient location. The VNA can compensate for the time
delay and other fixture losses.
You have calibrated the test system and you need to add a length of transmission line to the
configuration. Use port extensions to configure the length of transmission line in the VNA to account
for the losses introduced by the transmission line.

Procedure
1. Open the Port Extension dialog box in Response > Cal.
2. Check Enable Port Extension. This applies the port extension calculation to measurements. When
the calculation is complete, use the check box to apply/remove the length and loss and compare results.
3. Specify delay and loss values for the test port(s). In general, single port extensions apply to 1–port
measurements (S11, S22). Specify delay and loss values for both ports when performing 2–port
measurements (S11, S22, S12, S21).
If you know the physical length of the fixture or transmission line, specify this as the Delay Length. If
you know the electrical length instead, specify this as the Delay Time.
4. Enter the DC Loss value. This should offset the frequency span in the positive direction.
5. For Loss 1, specify the loss (in dB) and frequency for the lower frequency limit in the sweep. For
Loss 2, specify the loss (in dB) and frequency for the higher frequency limit. Use the check boxes to
enable/disable the loss values and compare how that affects your measurement.
6. Specify the Velocity Factor for the medium of extension. Typical values are:
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Medium

Velocity Factor

Polyethylene dielectric cable

0.66

PTFE Dielectric

0.7

Foamed polyethylene dielectric

0.82

Light in vacuum

1

xxx

7. Select the medium of the extension.
For a coaxial medium, you must also specify the velocity factor.
For a waveguide medium, you must also specify the cutoff frequency.

Loss calculation
These equations describe how the values of Loss1 and Loss2 (losses at the lower and higher frequency
limits in dB) affect the calculation of losses compensated by applying port extensions.

When Loss2 is specified:
The total loss at frequency f is given by

where:

When Loss2 is not specified:
The total loss at frequency f is given by
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Partial overwrite
In cases where you need to repeat a portion of the calibration procedure, for example a particular standard,
use the partial overwrite feature. The new measurement overrides the data previously recorded for that
standard. The VNA recalculates the calibration coefficients. Partial overwrite can happen only after
completing a calibration procedure. Use this feature when you want to do a partial recalculation of
calibration coefficients for a standard.
For example, if you are performing a 2–port SOLT calibration:
1. In Response > Cal > Calibrate, click 2–port SOLT. Open the dialog box for the calibration.
2. Step through Open, Short, and Load standard calibrations for port 1 and port 2.
3. Click Thru. You can now repeat calibration measurements for the two ports.
4. Click Overwrite. The VNA stores the second set of measurements and uses them to recalculate
calibration coefficients.
NOTE. You cannot use the partial overwrite feature to add additional calibration coefficients to a
calibration procedure. You can only update calibration coefficients that have already been calculated. For
example, if you perform a 1-port calibration, you cannot use the overwrite feature for the other port to
convert the 1–port procedure into a 2–port calibration.
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Manage calibration kits
The VNA is preloaded with 7 calibration kits. There are 13 additional empty kits that you can use to
create your own calibration kits. Adding a kit or modifying an existing one can be a useful option when
you need to:
Add a new calibration standard to a kit.
Improve the parameters of a calibration standard.
Assign a different port to a standard for connector matching.

Add/Modify a calibration kit
You add a calibration kit to the VNA by selecting an empty kit and modifying it. You can also use empty
kits to modify a preloaded calibration kit to change standards or parameters.
Since a calibration kit is a collection of standards in different subclasses (for various calibration
procedures), when you add a calibration kit, you must:
1. Define calibration standards.
2. Specify subclasses for the standards.

Define a calibration standard
To define a calibration standard, you must specify its calibration coefficients. You can define them in
two ways:
Model-based definition – Use coefficients of the nth degree polynomial equation that defines the
model of the standard.
Data-based definition – Obtain this information from the datasheet of a kit or import a touchstone file
(S1P, S2P) that describes the standard.
Once you have the calibration coefficients,
1. In Response > Cal > Cal Kit, select an empty user kit from the data entry bar. These are numbered
1–13.
2. Once you have selected a calibration kit, modify it by clicking Cal > Modify Cal Kit.
3. Define a calibration standard. Select Cal > Modify Cal Kit > Define Standards. Select a standard
and enter values for settings in the dialog box.
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Section

Parameter

Description

Identification

Label

Name of standard

Type

Type of standard. Select from:
Open
Short
Load
Thru
Unknown Thru
Arbitrary
None

File

File name

Frequency Range

Min
Max

Media

Coaxial

Import a touchstone file (S1P, S2P) that contains S-parameters and
other information about the standard. Select this option for a data-based
standard definition.
Define the complete frequency range of the standard. For a waveguide,
the cutoff frequency is the minimum frequency.
Define the medium of the standard.

Waveguide
Common
Characteristics

Delay

Electrical delay

Loss

Offset loss

(Z0)

Characteristic impedance
50 Ω (coaxial)
1 Ω (waveguide)

Open Characteristics

C 0, C1 , C 2 , C 3

Calibration coefficients

L 0 , L 1 , L 2, L 3
xxx

Specify a subclass
A subclass is a grouping of standards. A set of standards can be grouped in several different subclasses for
different calibration procedures. Each subclass must cover the entire frequency range of the calibration of
the standard. However, you can use individual standards to cover sections of the frequency range.
Different VNAs support different calibration kits and standards so you may need to redefine a calibration
kit when you import it. Since calibration standards are defined for 1 and 2 ports, standard subclasses
are also defined for 2–ports.
1. Select Response > Cal > Modify Cal Kit > Specify Subclass.
2. Select a subclass to modify. You can set an existing subclass (Male-Male DUT) or pick an empty
subclass. The subclass dialog box opens.
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3. Specify the SOLT or TRL standard settings for port 1 and port 2. Click Apply to save the subclass.
4. During calibration, when you select a user-defined standard, make sure you specify the subclass in
the Subclass Id field.
NOTE. When subclasses overlap for a portion of the frequency range of operation of a standard, the
subclass used for the most recent standard collection determines the calibration data stored by the VNA.
For example, if subclass 1 measures the response from 100 kHz-2 GHz and subclass 2 measures the
response from 1 GHz-4 GHz, the subclass 2 calibration data is stored by the VNA for the overlapping
frequency range of 1 GHz-2 GHz.

Label the calibration kit
After you create standards and specify subclasses for them, select Response > Cal > Modify Cal Kit
> Label Kit. Enter a name for the new calibration kit and save it.

Additional calibration kit operations
Task

Action (in Response > Cal)

Import a calibration kit file (from system or another
analyzer)

Cal Kit > Import

Export calibration kit file

Cal Kit > Export

Clear calibration data from the VNA

Clear

xxx

Calibration trigger source
In the default operating mode, you can select a trigger for measurements whereas calibration uses an
internal trigger. However, when you need to position or switch external hardware, you can set the
calibration trigger to be identical to the measurement trigger.
In Response > Cal > More > Cal Trig Source, set the calibration trigger to System.

Power calibration
For a more accurate calibration where the power output is closer to the set value or to compensate for
losses in external cabling and fixtures, use the power calibration feature. This option uses a power meter to
measure the power level and it uses calibration data to perform error correction. The accuracy of the power
setting at the point of calibration is fixed by the power meter. The accuracy and range of measurement can
be limited by the power meter as well as by the power supplied. Set the channel frequency range according
to the supported frequency range of the power meter.
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Power calibration applies to each port of the VNA so you can turn this feature on or off for each port
independently. You can also use different power meters at the two ports.

Power calibration workflow
In the power calibration workflow, you perform these steps:
1. Connect a power meter to the VNA at the test location where the cables and fixtures connect to
the DUT.
2. Configure the VNA for power calibration.
3. The power meter measures power at every frequency in the specified range and adjusts its output
to the selected power level.
4. Once the calibration is complete, you can save the power meter data as part of the VNA state data.
Remove the power meter. VectorVu-PC now applies the calibrated power data to all connections
at this port.
5. If you perform an S-parameter calibration with power correction turned on, the calibration uses the
power levels determined in the previous step.

Requirements
Review these requirements before you begin the power calibration procedure:

Power meters
Select one of these supported models:
Manufacturer

Type

Tektronix

USB

Models
PSM3000 series
PSM4000 series
PSM5000 series

Rohde & Schwartz

USB

NRP-Z power meters
NRP-xxS/SN power meters

Keysight

USB

U848x series
U2000 series
U2020 series

xxx

Loss compensation table
Prepare a loss compensation table in comma-separated value (CSV) format to account for the fixture
losses at every frequency. The first column indicates frequency (Hz) and the second column indicates
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the corresponding power loss (dB). Frequencies must be in ascending order and the file must contain at
least 2 sets of entries.

Power calibration factor table
Prepare the power calibration factor table in CSV format. This is a table of frequencies (Hz) and
corresponding calibration factor values (%). The calibration factor indicates the percentage of power
transmitted to the power meter and not reflected back to the fixtures.

Frequencies must be in ascending order and the file must contain at least 2 sets of entries. If you do not
specify calibration factors for specific frequencies, you can also provide a Reference Calibration (RC)
Factor that applies globally to every frequency in the table.

Procedure
1. Connect the USB cable of the power meter to the computer.
2. Connect the measurement port of the power meter to the test location. The test location includes all
cables and fixtures between the VNA and the DUT.
3. In Cal > Power Calibration, select the port where you want to perform power calibration.
4. Click Configure. In the power calibration dialog box, you enter parameters to set up power calibration
for the selected port.
5. Refresh the Model Address field. The VNA detects the power meter connected to your system.
6. Specify the averaging factor. This refers to the number of power calibration measurements to be
averaged at a single point.
7. Specify a tolerance value. This value should be large enough to accommodate losses in frequency
response due to cables and fixtures. When consecutive power measurements are within this range, the
power meter settles on the measurement and the VNA stores this reading.
8. If you want to compensate for losses in fixtures and cables, check Enable Loss Compensation. Select
a CSV file that contains the loss compensation data.
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9. In Sensor Calibration, select a CSV file that contains the power calibration factor table for the
sensor. If the table does not contain individual calibration factors, specify an RC factor that applies
globally to all entries in the table.
10. Apply these settings. You can save them as part of the instrument data in a state file (*.state or
*.cstate) format.
11. After configuring the power measurement, you can measure S-parameter measurements for the DUT
using the corrected power levels for stimulus. Select Cal > Power Calibration > Calibrate.
You can now enable or disable power calibration by toggling the Correction soft key. The correction
applies to any connection you make at this port.

Receiver calibration
When you measure active devices that require accurate absolute power (like amplifiers or frequency
converters), use receiver calibration to calibrate the gain of the individual receivers. In this calibration:
1. You perform a power calibration on the source port. This procedure corrects the output power of
the source port by compensating for:
Power loss in the VNA.
Losses in cables and fixtures connected to the source port.
2. You connect the calibrated source port to the receiver port of the VNA (thru connection). The receiver
port can include cables, fixtures, and other hardware.
3. Perform receiver calibration. Through this procedure, you move the calibration reference plane to the
point where the receiver test port is connected to the calibrated test port.
NOTE. You must complete a power calibration before performing a receiver calibration.

Procedure
1. Complete a power calibration on the source port.
2. In Response > Cal > More, select Receiver Calibration.
3. Select Calibration. The Receiver Calibration dialog box opens.
4. Select the receiver and source ports.
5. Click Calibrate. Once the calibration is complete, the error correction is enabled on the receiver port.
You can disable it in Receiver Calibration > Error Correction.
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See also:
Power calibration
The calibration plane

Unknown thru calibration
When the thru standard for a calibration is either undefined or unavailable at the test location, use
the unknown thru calibration feature. When you define a thru standard, you specify delay and loss
characteristics for the standard and therefore, you need to know these values at the time of definition. In
the unknown thru calibration, the VNA allows you to define a thru standard without specifying these
parameters.
Use unknown thru calibration when:
You cannot define or measure in advance the attributes of a thru standard.
The test reference planes are fixed and cannot be moved to connect a known thru standard (like a
waveguide).
In Response > Cal > Modify Cal Kit > Define Standards > Thru select the Unknown Thru option.
The unknown thru loss impacts the accuracy of the calibration, and hence the measurement accuracy.
The unknown thru must be reciprocal (S21=S12).
NOTE. The accuracy of a Thru standard with specific delay and loss characteristics is always higher
than the accuracy of an Unknown Thru standard.
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Set trigger for measurement

Set trigger for measurement
You can set the VNA to perform a sweep or point measurement every time the VNA detects a trigger
signal. You can also use triggers to synchronize measurements with external events (like closing switches)
or equipment.
To set triggers for measurements,
1. Set a trigger source (applies to all channels).
2. Set a trigger mode for every channel.
3. Set the trigger scope.
4. Generate the trigger.

Sweep order in each channel
Trigger signals sweep through a frequency range until all traces in the channel have been triggered.
Within a channel, the trigger signal sweeps through traces sequentially in source-port order. So, for a
2–port measurement, the trigger signal sweeps the traces of source port 1 (S11 and S21) simultaneously.
This is followed by the sweep of traces of source port 2 (S22 and S12).
Once a channel has been completely triggered (all traces swept), the trigger applies to the next channel
that is not in a hold state.
The trigger sweep order applies to all trigger modes.

Set a trigger source
You use the trigger source to generate a trigger signal that initiates the measurement. Select a trigger
source in Stimulus > Trigger > More > Trigger Source.
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Set trigger for measurement

No.

Source

Description

1

Internal

The TTR500 VNA hardware generates an internal signal. This is the
basic mode of operation for continuous sweep.

2

External

Connect an external trigger signal directly to the TTR500 device using
the BNC cable. Connect to Trigger In port of rear panel.

3

Manual

In Stimulus > Trigger > More, press the Trigger button to initiate a
sweep. Upon receipt of the trigger request, VectorVu-PC relays the
trigger request to the TTR500 hardware through the USB cable that
connects the VNA to the computer.

4

SCPI

Execute the *TRG SCPI command through a programmatic interface.
VectorVu-PC detects the command and sends the trigger to the VNA via
the USB cable that connects the VNA to the computer.

xxx

NOTE. When you provide a manual trigger or select the SCPI source, the trigger pulse is generated
through VectorVu-PC. There is an execution time involved as the pulse passes through the workstation
running VectorVu-PC and the USB cable connecting it to the TTR500 device.

Measurement and calibration trigger sources
In the default operating setting, the trigger source for a sweep measurement is different from the calibration
trigger source. See Calibration trigger source for more information.

Set a trigger mode
Set the trigger mode for every channel to control its trigger operation. When you set the trigger mode for a
channel, you also set the state of the channel for the trigger sweep. Select a trigger mode in Stimulus
> Trigger.
Mode
Hold

Sequence of operation
Pause the sweep on the active channel and hold it in idle status.
VNA ignores triggers in this mode.

Single sweep (Single)

VNA is in hold state.
Click Trigger > Single to change to armed state and await trigger.
VNA performs a sweep upon trigger and returns channel to hold state.

Continuous sweep (Continuous)

This is the default mode.
VNA is always in armed state (never in hold state).
Trigger signal causes VNA to perform a sweep and return to armed state.
Repeat sweep every time trigger source detects a trigger signal.
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Mode

Additional trigger options
Sequence of operation

Hold All Channels

Set the mode for all channels to Hold.

Continuously display channels
(Continuous All Channels)

Set the mode for all channels to Continuous.

xxx

NOTE. The hold state is an idle state for the VNA where all activity is frozen and triggers are ignored. You
can switch to single or continuous mode from the hold state by selecting either option in the Trigger menu.

Set the trigger scope
Set the scope of the trigger to apply to all channels (default setting) or only the active channel.
You can set this in Stimulus > Trigger > More > Trigger Scope.

See Also
Additional trigger options
Averaging
Sweep time calculation

Additional trigger options
Point trigger
Use the point trigger feature to obtain a point measurement instead of a sweep measurement at each
trigger event. The generation of trigger signals causes the VNA to record measurements one frequency
point at a time.
Click Stimulus > Trigger > More > Point Trigger to enable point trigger mode.

External trigger delay
You can set a delay to the external trigger signal. In Stimulus > Trigger > More > Ext Trig Delay,
set a delay within the range of 0–1 second. Upon receipt of a trigger signal, the triggering action is
delayed by this time.
Use the external trigger delay function to handle electrical or mechanical delays in external equipment
involved in the test setup.
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Averaging

See Also
Averaging
Sweep time calculation

Averaging
You can set the VNA to record an average of measurements per frequency point. In Response > Avg:
1. Select Averaging and enable the function.
2. Select Factor and specify a value for the averaging factor. This is the number of measurements to
average at a frequency point.

Averaging and triggers
When you enable averaging,
1. Each trigger causes the VNA to complete a frequency sweep measurement and average it with any
previous sweep measurement(s) recorded.
2. A counter in the instrument status bar displays a ratio of the number of sweep measurements recorded
(n) over the specified averaging factor (m). The counter increments every time you generate a trigger ,
until the averaging factor is reached.
3. Once the averaging factor is reached, any additional trigger(s) causes the VNA to perform a sweep
measurement and calculate a weighted average with all previous sweeps.

Averaging with point trigger
The behavior is similar to averaging in normal triggered mode with the exception that each trigger causes
the VNA to complete a measurement at a frequency point instead of a full sweep. The VNA averages at
each frequency point before moving to the next point.

Averaging trigger function
When point trigger is disabled, the averaging trigger function allows you to perform a single sweep per
trigger signal where every point on the sweep is averaged as many times as specified in the averaging
factor. Click Response > Avg > Avg Trigger to enable the feature.
NOTE. You must have the averaging function enabled to use the averaging trigger.
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Sweep time calculation

When point trigger is enabled, the averaging trigger function causes the VNA to complete as many
measurements as the averaging factor at a single frequency point. Successive triggers cause the VNA to
advance to subsequent points.

See Also
Set trigger for measurement
Additional trigger options
Sweep time calculation

Sweep time calculation
Continuous sweep
In the continuous sweep mode, the time taken to complete a sweep through n frequency points is
calculated as:

where:
n : Number of points in sweep
C0 : Sweep delay
C1 : Time required to set up a sweep
C2 : Time required to set up each point in a sweep
C3/IFBW : Time required to make a measurement at a frequency point. This value is inversely proportional
to the IFBW.
Tn : Total time required to complete a measurement at nth frequency point
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Sweep time calculation

Trigger sweep
When you make a trigger sweep measurement, the sweep begins at the falling edge of the trigger pulse.
Any delay provided to the trigger signal (through Stimulus > Trigger > More > Ext Trig Delay) applies
between the detection of the trigger signal and the sweep delay.

See Also
Set trigger for measurement
Additional trigger options
Averaging
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Use markers on a trace
A marker reads the numerical value of a stimulus and the corresponding response value on a trace. In the
rectangular format, the stimulus value is read off the X-axis and the response value is read off the Y-axis.
In the polar and Smith chart formats, the stimulus value is on the X-axis. The corresponding marker on the
chart represents the main and auxiliary value of the measured response value.
You can add up to 9 markers on a trace. You use markers to:
Read the measured response for a stimulus at any point on the trace.
Adjust the scale by setting the reference line to the marker position.
Search for a point on the trace.
Move to a specific point on the trace.
Change stimulus parameters.
Analyze trace parameters.
For a particular trace on a channel, to add a marker:
1. In the Markers/Analysis option group, select Setup.
2. Select a marker (1–9).
You can also set a reference marker in Setup > More by selecting the Ref Marker option.

See Also
Set up marker display
Reference markers

Set up marker display
These topics cover several display settings you can select for markers:
Select a display mode
Relative value display (Delta mode)
Couple/Decouple markers
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Marker display format
When you add a marker to a trace, the marker appears as a pair of triangles – one on the trace at the
specified frequency value and the other on the X-axis (rectangular format) or base of the plot (Smith or
Polar formats). The marker data (stimulus and response values) are displayed in the upper left corner of
the respective channel display.
In the rectangular format, the marker data shows the measured response and stimulus values.
In polar and Smith chart formats, the marker data shows these parameters.
Data Format

Marker data (response value)
Main value

Auxiliary value

Smith chart – Lin/Phase

Linear amplitude

Phase

Smith chart – Log/Phase

Log amplitude

Phase

Smith chart – Real/Imag

Real component

Imaginary component

Smith chart – R+jX

Resistance

Reactance

Smith chart – G+jX

Conductance

Susceptance

Polar – Lin/Phase

Linear amplitude

Phase

Polar – Log/Phase

Log amplitude

Phase

Polar – Real/Imag

Real component

Imaginary component

xxx
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Select a display mode
Where you can place a marker on a trace depends on the display mode you select for the marker.
In the discrete mode, you can place markers only on actual measurement points and not those points
interpolated between them. If the stimulus value is a specific numerical value, the VNA places the marker
on the measurement point that is nearest to the value (unless the value falls on a measurement point).
In the continuous mode, you place markers on actual measurement points as well as the interpolations that
happen between them.

Select one of these modes in Markers/Analysis > Function > Discrete.
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Relative value display (Delta mode)
In the default mode, a marker displays the response value relative to the origin of the chart. In the delta
mode, you set a reference marker to display marker data relative to that reference point. The marker data
displays the deltas on the axes relative to the reference marker.

1. Set a reference marker on a point of interest. In Markers/Analysis > Setup > More, select Ref
Marker and assign the marker to a reference point.
2. Add markers to the trace. Select from 1–9.
3. In Markers/Analysis > Setup > More > Delta mode, select delta mode in the pull down menu. The
marker data displays the relative difference between its value and the reference. A delta sign appears
in the marker information in the display graph.

Couple/Decouple markers
When you set up the same marker number to different traces on the same channel, you can couple and
move them together or you can choose to move them independent of each other. Turn coupling on or off
in Markers/Analysis > Function > Couple. The coupling happens between markers of the same index
across all traces in the channel. For example, if marker 3 on trace 2 is set to be coupled, then marker 3
on all traces move together. Correspondingly, if the marker has a tracking search configured, then all
coupled markers move with it on each new sweep.
You cannot couple markers across different channels. Marker couplings are independent from each other.

Marker search operations
Use options in Markers/Analysis > Search to perform these search operations:
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Target points on the trace
Peak points on the trace
Bandwidth of the trace
Bandwidth using notch search
When you perform a marker search operation on a trace, the VNA moves the marker from its current
position to the new measurement point located through the search operation.

Set search range
In the Search Range option set, you can search for points on the entire range of a sweep (Entire sweep
range) or a part of it (Arbitrary range).
If you choose to search a portion of the sweep range, specify the range using Start and Stop options in
the Search Range option set.
You can also choose to couple or decouple multiple traces for the search operation. In this case, the
coupling happens between markers of the same index across all traces of the same channel. Therefore,
you can have a marker on each trace with a search configured for it. You can then define the search range
for all of these markers in one place.

Maximum and minimum values
When you search for the maximum (Max) and minimum (Min) measured response values on the trace in
Markers / Response > Search, the VNA moves the marker to the respective stimulus values.
In Smith or polar formats, you search for the measured response value only.

Search tracking
Set the Markers / Analysis > Search > Tracking function for the VNA to perform a search operation
every time a sweep is completed.
When search tracking is off, the VNA performs a search at the moment it is configured, and the marker
stays at the search location even when the sweep changes. When you enable search tracking, the VNA
executes a search at the end of each sweep, and the marker moves accordingly. Therefore, if you have a
marker configured to search for the maximum value on a trace, the marker moves to the maximum point,
on the next sweep, the maximum point could be elsewhere on the trace. With search tracking enabled, the
VNA executes the search again on a new sweep measurement and the marker moves to the maximum
point on the new sweep.
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Target search
You perform a target search when you search for a specific point on the trace whose measured value
matches the specified target.

1. Select Markers/Analysis > Search > Target.
2. Specify a Target Value to search on the trace.
3. Specify a Target Transition. A positive transition is along those edges where successive points are
numerically higher than preceding points. A negative transition occurs when successive points are
numerically lower than preceding points. When you select both transitions, you search both positive
and negative transitions.
4. Click Search Target.
Besides the target transition, you can also specify the direction of the search (Search Left / Search
Right) from the position of the marker. When you specify the direction, you execute the search and the
marker moves to the new point.
The search target operation returns the matching target that is nearest to the current location of the marker.
If the current location of the marker matches the target, the marker does not move. The Search Left /
Search Right functions return the nearest matching target in the relevant direction, even if the current
point also matches the target. When you clicking Search Left or Search Right repeatedly, the marker
moves in the corresponding direction from the first matching point to the next.
NOTE. When you use target search, regardless of continuous or discrete mode, the search returns the
nearest measurement point that satisfies the specified conditions of target value and transition type.
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Peak search
A peak is a measurement point on the trace that is either higher (positive) or lower (negative) than
points on either side of it.

To perform a peak search (Markers / Analysis > Search > Peak),
1. Specify a Peak Excursion value. This is a parameter that is useful when searching for peaks in noisy
traces. Use peak excursion to disregard noisy peaks and locate only those peaks that are relevant to
your search. Mathematically, this is the smaller of the differences of the adjoining peaks of opposite
polarity from the measured point.
2. Specify a Peak Polarity to search for positive, negative or peaks of both polarities from the current
marker position.
3. Specify the direction (Search Left or Search Right) in which you are searching for the next peak.
The VNA moves the marker to the first peak encountered in that direction that meets all the criteria. Note
that this may not necessarily be the peak with the largest deviation.
In the Smith and polar formats, you use peak search for the main response value of the two marker
response values.

Bandwidth search
You perform the bandwidth search to determine the bandwidth of a trace. The bandwidth search also helps
you to identify the following parameters associated with a stopband or passband based on the stimulus
value of the active marker:
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The low and high frequencies (flow and fhigh) separated by the bandwidth
The bandwidth of the trace, calculated as the difference between the high and low frequencies.
The center frequency (fcenter) from where the bandwidth is measured.
The Q value (center frequency divided by the bandwidth)
The insertion loss, specified by the position of the marker at the time you perform the search.

To perform a bandwidth search,
1. Place the marker at the desired stimulus value. The marker response value is the insertion loss.
2. In Markers/Analysis > Search > More > Bandwidth Value, enter a numeric value for the bandwidth.
3. Click the Markers/Analysis > Search > Bandwidth toggle button to enable the search.
The VNA displays high and low frequencies, the center frequency, bandwidth, insertion loss and Q
value in the upper left corner of the channel display.
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Notch search for bandwidth

NOTE. The bandwidth search executes when you click the Bandwidth toggle button ON. If you have
selected tracking, the bandwidth search always executes on a new trace.

Notch search for bandwidth
The notch search method is an alternative method to the bandwidth search that yields bandwidth
parameters.
In the notch method, you specify a notch value to commence the search. The VNA begins the search on
the left side of the marker position and completes the search when it locates a pair of points that are at
the specified notch value. The frequencies obtained from those points are the lower and higher cutoff
points. The notch search also displays the center frequency, bandwidth, Q value and insertion loss at the
marker position.
To perform a notch search for the bandwidth of a trace,
1. Place the marker at the required measurement point. The marker response value is the insertion loss.
2. In Markers/Analysis > Search > More > Notch Value, enter a numeric value for the notch.
3. Click the Markers/Analysis > Search > Notch toggle button to enable the search.
The VNA displays lower and higher cutoff frequencies, the center frequency, bandwidth, insertion loss
and Q value in the upper left corner of the trace.
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NOTE. The notch search executes when you click the Notch toggle button ON. If you have selected
tracking, the notch search executes again for every new sweep.

See Also
Bandwidth search
Peak search

Trace data math operations
When you display a trace with measured data in VectorVu-PC, you can save a copy of the trace in the
VNA as a memory trace. You do this by selecting the Data → Mem option in Response > Display
> Memory. The memory trace is saved in the VNA until the next time you perform the operation,
whereupon the memory trace is overwritten with the current data trace. Additionally, the memory trace is
deleted if you change the number of points.
Use the memory trace to compare trace measurements with the data trace. You can also perform these
math operations in Response > Display > Memory > Data Math. These math operations apply to every
point on the data trace and its corresponding point on the memory trace.
Trace operations are done in the linear magnitude and phase format:
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A division of two quantities expressed as linear vectors is the equivalent of subtracting dBs and
subtracting phase angles.
A multiplications of two quantities expressed as linear vectors is the equivalent of adding dBs and
adding phase angles.
Operation

Description

Data / Mem

Divide data trace by memory trace

Data * Mem

Multiply the data and memory traces.

Data - Mem

Subtract the memory trace from the data trace. Use this operation to deduct a measured
error from the test data.

Data + Mem

Add the memory trace to the data trace.

Off

Turn off all data math operations.

xxx

To perform these math operations,
1. Set up a trace measurement.
2. Save the data trace to memory in Display > Memory > Data → Mem.
3. Display the data and memory traces. Select Display > Memory > Display Content > Data & Mem.
NOTE. When you select Scale > Auto Scale, the VNA scales the X and Y axes to display the data trace to
scale. If the data and memory traces are near similar, you may not be able to see both of them clearly
using the auto scale feature. Scale manually to zoom in and see the two traces. In cases where the data
and memory traces are identical, you can display each trace separately by turning the other one off.
4. Select the mathematical operation you want to perform in Display > Memory > Data Math. The
VNA performs the operation and modifies the display accordingly.
5. When you have finished your math operation, select Display > Memory > Data Math > Off to turn
off data math. If necessary, you can save the trace using System > Save/Recall > Save.
NOTE. The math operations apply to the data trace only. You save the data trace to memory in order to
reflect the changes in the memory trace. You can disable the display of the data trace but this does not
disable the update to the trace as a result of the data math operation.

Normalize data
Normalizing is the process of performing a logarithmic division of every point on the data trace with
its corresponding point on the memory trace. The Normalize feature automates the tasks of saving
a memory trace and performing a Data/Mem operation. Use this feature when you need to perform
these operations repetitively.
In the Response option group, select Display > Memory > Normalize.
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See Also
Target search
Bandwidth search

Save VNA state
At any time when using the VNA, you can save the state of the instrument or recall a saved state. In the
System option group, select Save/Recall > Save and the data type to save.
The VNA gives you options to save these types of data:
Data

Format

Description

State

*.state

Save VNA settings.

State+calibration

*.cstate

Save VNA settings and calibration data.

State+data

*.dstate

Save VNA settings and trace data.

State+calibration+data

*.cdstate

Save VNA settings, calibration information and trace data.

xxx

Save and recall trace/channel
To save all channels and traces, select Save/Recall > Save.
When you save all channels and traces, use Save/Recall > Recall to recall this information and select
All state files(*.*state) when browsing in the file browser.

See Also
Recall saved data
Save touchstone (SnP) files

Recall saved data
You can retrieve saved data in the VNA when the information is in one of these formats:
State (*.state)
State+calibration (*.cstate)
State+data (*.dstate)
State+calibration+data (*.cdstate)
All state files (*.*state)
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Limitations when recalling data
You can only retrieve measurement data saved using a TTR500 series instrument. You cannot retrieve
information saved using a network analyzer from another vendor.
Calibration and state information are unique to an individual VNA at a particular time and in a specific
environment. You cannot share calibration data (*.cstate files) between different TTR500 series
instruments.
The data saved in a VNA is specific to the environment of the instrument. When you recall the
saved state of an instrument (*.state or *.dstate file) and reinstate these settings, the VNA can behave
differently if the operating conditions have changed from the time the information was saved.

See Also
Save VNA state
Save touchstone (SnP) files

Save touchstone (SnP) files
You can save s-parameter information from the VNA for 1–port and 2–port models in the touchstone
format. Touchstone files contain S-parameters of the DUT in a space-separated format. The number of
ports used in the measurement determines the matrix of S-parameters for the DUT and consequently, the
format of the touchstone file.
For example, a 2–port model results in the measurement of 4 S-parameters in a 2x2 matrix: [S11 S12 S21
S22]. The corresponding touchstone file that contains these S-parameters is an S2P file.
The TTR500 series VNAs support S1P and S2P formats for 1–port and 2–port models respectively. The
S-parameters are recorded as complex numbers that indicate:
Linear magnitude+angle (dB)
Logarithmic magnitude+angle (MA)
Real+imaginary (RI)
In a touchstone file, the behavior of the DUT is completely represented by the collection of its
S-parameters. You can import the touchstone file into a data modeling program or circuit simulator like
MATLAB or Keysight Advanced Design System (ADS). Use the S-parameter representation of the DUT
when you build and simulate models in these programs.
1. For the active trace, in the System option group, specify the representation of the S-parameter complex
form in Save/Recall > Save SnP > SnP Format. When you select Auto, the VNA retains the default
format in which S-parameters are recorded on the trace.
2. Select the format of the touchstone file (S1P or S2P). For an S1P file, select the port at which you are
measuring the DUT.
3. Save the touchstone file.
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NOTE. When you save data to a touchstone file in the sweep mode, the VNA saves data from the previous
sweep in the touchstone file. If a sweep operation has not occurred by the time you save data, no
information gets stored in the touchstone file. For this reason, set the active channel to Hold when saving
data in sweep mode in a touchstone file.

S1P files
An S1P file represents S-parameters for a 1–port measurement. The header contains information obtained
in response to the *IDN? query. The data portion of the file contains a list of frequencies along with
corresponding S11 or S22 values (in complex format), depending on the port used for measurements.

S2P files
An S2P file represents S-parameters for a 2–port measurement. The header contains information obtained
in response to the *IDN? query. The data portion of the file contains a list of frequencies along with the
matrix of S-parameters for a 2–port device (S11, S12, S21, and S22). The S-parameters are in complex
format, depending on the port used for measurements.
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Expand dynamic range

See Also
Save VNA state
Recall saved data

Expand dynamic range
The noise floor of the VNA is the minimum power level at which you measure with the VNA. The span
from the noise floor to the maximum input power level is called the dynamic range of the VNA. When
you need to evaluate large amplitude spans, it is useful to expand the dynamic range. You do this by
lowering the noise floor.
To lower the noise floor, you can:
Narrow the IF bandwidth
Enable sweep averaging

Narrow the IF bandwidth
When you lower the IF bandwidth, you reduce the effect of extraneous noise on the measurement. To
change the IF bandwidth, click Response > Avg > IF Bandwidth and enter a new value.

Enable sweep averaging
When you perform sweep averaging, you calculate the data average of every vector point on the sweep,
based on the exponential average of a continuous sweep. The exponential average is weighted by an
averaging factor that you specify.
For any point that is a vector quantity, the sweep averaging (An) for the nth sweep operation at that point is:
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Improve phase measurement accuracy

Here Sn is the measurement value at the nth sweep operation at that measurement point. F is the sweep
averaging factor, ranging from 1 to 999.
For the active channel,
1. In Response > Avg, click Averaging and enable the feature.
2. Click Factor and enter a value between 1 and 999.
Click Restart to reset the value of n to 1 in the sweep averaging equation.

See Also
Improve phase measurement accuracy
Improve measurement throughput

Improve phase measurement accuracy
Use these settings to improve the accuracy of phase measurements using the VNA.
Electrical delay
Phase offset
Apply port extensions

Electrical delay
Electrical delay is a mathematical function that introduces a phase shift, similar to transmission through a
lossless delay line. You can use this function to examine the deviation of a phase measurement or Smith
chart measurement from a linear phase response.
You can specify the electrical delay for each trace. Depending on the type of medium (coaxial or
waveguide), the calculation of the electrical delay varies.
For the active trace,
1. In Response > Scale > More, select Electrical Delay. A dialog box opens.
2. Enter the delay value as a length of lossless transmission line (m) or a measure of time (seconds).
3. Specify a velocity factor. Typical values are:

78

Medium

Velocity Factor

Polyethylene dielectric cable

0.66

PTFE Dielectric

0.7
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Medium

Velocity Factor

Foamed polyethylene dielectric

0.82

Light in vacuum

1

xxx

4. Select the medium of the delay line. For a waveguide medium, you must also specify the cutoff
frequency.

Phase offset
When you know the amount of phase adjustment to include in a measurement, use the phase offset feature
to make the correction. This option allows you to include a predetermined value to the frequency to
account, for example, the addition of a cable.
In Scale > Phase Offset, specify a phase offset value between –360 ° to +360 °.

See Also
Expand dynamic range
Improve measurement throughput
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Improve measurement throughput
Use these settings in the VNA to improve the measurement throughput:
Switch off information update
Switch off error correction

Switch off information update
Each time you make a measurement, VectorVu-PC and the VNA consume additional time to update graph
displays dynamically. When you do not need to inspect measurements and changes in the display graph at
the time you make the measurements, switch off dynamic updates in the software.
In the Display option group, click the Update button to toggle the setting off. The Instrument Status bar
indicates ‘Update off’.

Disable factory error correction
The VNA uses factory calibration data to implement a factory error correction to your measurements. This
factory correction is available if you do not want to calibrate the VNA in a specific configuration. The
factory correction is not required if you perform:
VNA calibration procedures for S-parameters as described in this manual.
Power calibration
Receiver calibration
Proper calibration of the VNA automatically turns on an error correction that supersedes the factory
correction. Measurement accuracy improves when you enable the error correction by calibrating the VNA.
To improve your measurement throughput, switch off the factory correction.
In System > More > System Correction, click the System Correction button to toggle the setting off.
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System option group
The System option group contains several settings and features to help you customize the operation of
your VNA:
Save/Recall
Preset
Language
In System > More, you can set these additional options:
Bias Tee
Reference Clock Source
Beep
System Correction
Connections
Simulator
Log Severity
OPC Logger

Save/Recall
Use the options in this set to save channel and trace information to your system.

See Also:
Save VNA state
System option group
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Preset
Use System > Preset to restore the state of the VNA to factory settings.

See Also:
System option group
Default settings for System options

Language
You can configure the user interface of VectorVu-PC dynamically in any of these languages:
English
Japanese
Korean
Vietnamese
Chinese
Taiwanese Mandarin

See Also:
System option group
Default settings for System options
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More options
Toggle these options to set or clear them in the VNA by clicking the respective buttons. You can see the
current setting in the Data Entry bar.
Option

Description

Settings

Bias Tee

Enable bias tee function.

On/Off

Reference Clock Source

Set the reference clock source

Internal / External

Beep

Test and use a beep alert for system
actions

Beep Warning – beep when the VNA
displays a warning
Test Beep Warning – test the Beep Warning
function

System Correction

Apply factory error correction
(Enable/disable factory error
correction function)

On / Off

xxx

See Also:
Connections
Default settings for System options
System option group

Connections
The Connection Manager window displays the instruments that VectorVu-PC can detect. These are:
TTR500 series VNAs connected to your system
Internal simulator available in VectorVu-PC. This is a software application that allows you to operate
VectorVu-PC without an instrument connection.
For each device, you can see these details:
Model number of the VNA unit
Firmware version of the VNA
Connection status of the instrument
Software version of VectorVu-PC simulator
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Use Connection Manager
Use Connection Manager to pair TTR500 series VNAs with one or more instances of VectorVu-PC. When
you connect a TTR500 series VNA to your Windows machine, the system recognizes and copies over
driver files from the VNA device. Connection Manager uses these files to identify the VNA.
1. Open Connection Manager in System > More > Connections. In the display window, you see a
list of VNA devices associated with the current instance of VectorVu-PC. This list includes current
VNA connections as well as units connected previously. The list also includes the simulator internal
to the software.
2. Select the VNA device that is currently connected to your machine. If you have multiple units
connected to your machine, the unit that is controlled by VectorVu-PC displays as ‘Connected’. To
operate in simulation mode, select simulator.

This table explains the various states of VNA connections:
Connection
information

States

Description

Connection

Connected

The active instance of VectorVu-PC currently controls
the VNA.

Disconnected

The active instance of VectorVu-PC does not control the
VNA. (default for new connection)

Not Activated

VectorVu-PC has not copied the calibration files of the
VNA. (default for new connection)

Activated

VectorVu-PC has copied the calibration files of the VNA
from the non-volatile instrument memory to PC.

Claimed

An instance of VectorVu-PC controls the selected VNA.
If a VNA is connected to an instance of VectorVu-PC,
the instrument appears as ‘claimed’ in other instances
of the software.

Not Available

VNA is not currently connected to the computer via USB.

Available

VNA is communicating with the computer via USB

Activation

Availability

xxx

3. If you are connecting the VNA to your computer for the first time, click Connect. VectorVu-PC copies
the calibration files of the VNA and activates the VNA.
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Simulator

Once you connect a VNA to an instance of VectorVu-PC, that instance of the software ‘claims’ the
VNA. Thereafter, the device appears as ‘claimed’ in other instances of VectorVu-PC.
4. Check Reconnect automatically. VectorVu-PC connects to the VNA the next time you enable a USB
connection. You can change the active connection in Connection Manager at any time.
NOTE. You can see the name of the active connection in the title bar as well as the tool tip of the instrument
connection icon in the Instrument Status bar.

See Also
System options
Simulator

Simulator
VectorVu-PC has an internal VNA simulator that you can use for analysis without a TTR500 unit. Use
Connection Manager to switch to simulator mode. When you connect the simulator, the Instrument Status
bar turns gray. This is because the information in the Instrument Status bar only applies to measurements
made using TTR500 units.
Click System > More > Simulator to open the simulator submenu. These options are available:

Load SnP
When you use the internal simulator in VectorVu-PC, use the Load SnP function to load data in the SnP
(Touchstone) format for offline analyses. The SnP file completely represents the S-parameters of a DUT.
When you use the SnP file of a DUT in the offline (simulator) mode:
You do not need the actual DUT for analysis. Therefore, you can share parameter data with other users.
You do not need to be at the test location to analyze the data.

Noise Floor
Set the noise floor level for your measurements using the Noise Floor function. The noise floor is the
sum of all noise sources and unwanted signals in the VNA. It limits the smallest measurement that can be
isolated from the noise. Ideally, a lower noise floor is better for more accurate measurements.

See Also
System options
Connections
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Log severity and OPC logger
If you notice a problem in the performance of your VNA that indicates a service issue, use the log severity
and OPC logger options to create and send log files to Tektronix. These settings allow you to change the
type of information that the device logs. Use these options in combination to log the performance of
the VNA.
When you need to debug errors in the performance of the VNA:
1. Change the default settings for these options in System > More.
Option

Default setting

Change to..

Log Severity

Warning

Debug

OPC Logger

OFF

ON

xxx

2. When the error occurs again, OPC logger records this information in the log files. Send the log files to
a Tektronix service professional to further investigate the problem.

See Also
System options
Connections
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Stimulus options
Parameter / Setting

Location

Description

Default value

Scope

Start frequency

Start

Start frequency of
sweep

300 kHz

Channel

Stop frequency

Stop

Stop frequency of
sweep

6 GHz

Channel

Center frequency

Center

Center frequency of
sweep

3.0015 GHz

Channel

Span frequency

Span

Frequency span of
sweep

5.9997 GHz

Channel

Power level

Sweep Setup >
Power Menu >
Power Level

Set output power level

0 dBm

Channel

Port couple

Sweep Setup >
Power Menu > Port
Couple

Apply same/different
power settings on both
ports

YES (same power
settings)

Channel

Port power

Sweep Setup >
Power Menu > Port
Power

Power settings per port

0 dBm

Channel

Slope value

Sweep Setup >
Power Menu >
Slope Value

Enter dB/GHz change
from start to stop

0 dB/GHz

Channel

Power slope

Sweep Setup >
Power Menu >
Slope

Enable/disable power
slope

NO (disable power
slope)

Channel

RF output

Sweep Setup >
Power Menu > RF
Out

Enable/disable RF
output

NO (disable RF output)

Channel

Auto sweep time

Sweep Setup >
Auto Sweep Time

Enable/disable auto
sweep time

NO (disable auto
sweep)

Channel

Sweep time

Sweep Setup >
Sweep Time

Set sweep time

20.301 ms

Channel

Sweep delay

Sweep Setup >
Sweep Delay

Set delay to sweep.

0 sec

Channel

Points

Sweep Setup >
Points

Set frequency points in
sweep

201

Channel

Sweep type

Sweep Setup >
Sweep Type

Set type of sweep

Linear frequency

Channel

Avoid spurious

Sweep Setup >
Avoid Spurious

Avoid spurious

YES

Channel
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NOTE. The default
setting changes to NO
in simulator mode.
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Parameter / Setting

Location

Description

Default value

Scope

Trigger source

Trigger > Trigger
Source

Select the trigger
source

Internal

Channel

Point trigger

Trigger > Point
Trigger

Enable/disable a point
measurement at every
trigger

NO (disable point
trigger)

Channel

xxx

See Also
Channel / Trace options
Response options
Markers / Analysis options
System options

Channel/Trace options
Parameter / Setting

Location

Description

Default value

Scope

Active channel

Channel > Active

Select active channel

1

Channel

Number of channels

Channel > Num
Channels

Select number of
channels

1

Channel

Active trace

Trace > Active

Select active trace
number

1

Trace

Number of traces

Trace > Num Traces

Select number of
traces per channel

1

Trace

Active window

Window > Active

Select active window

1

Channel

Channel layout

Channel > Channel
Layout

Set channel layout.

D1

Channel

xxx

See Also
Stimulus options
Response options
Markers / Analysis options
System options
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Response options
Parameter / Setting

Location

Description

Default value

Scope

Format

Format

Select format to display
data

Log Mag

Channel

Phase units

Format > More >
Phase Units

Select unit of phase

Degrees

Channel

Divisions

Scale > Divisions

Select number of
vertical divisions on
graph

16

Channel

Scale per division

Scale > Scale/Div

Select number of units
per vertical division

10 dB

Channel

Reference position

Scale > Reference
Position

Select reference
position on graph

15

Channel

Reference value

Scale > Reference
Value

Select measurement
value at reference
position

0 dB

Channel

Electrical delay

Scale > More >
Electrical Delay

Mathematically correct
for an electrical delay
in measurement

0s

Trace

Phase offset

Scale > More >
Phase Offset

Mathematically correct
for a phase offset in
measurement

0 degrees

Trace

Title label

Display > Labels >
Display Title Label

Display title label

YES

Trace

Graticule label

Display > Labels >
Graticule Label

Display graticule label

YES

Trace

Frequency label

Display > Labels >
Frequency Label

Show/hide frequency
label

YES

Trace

Invert color

Display > Invert
Color

Invert trace and
background colors

Normal

Trace

Graph update

Display > Update

Turn ON/OFF
measurement graph
update

YES (turn ON update)

Analyzer

Menu bar

Display > Menu Bar
> Display Menu Bar

Show/hide menu bar

YES (show menu bar)

Analyzer

Bar font

Display > Menu Bar
> Bar Font

Select menu bar font
size

14

Analyzer

Averaging factor

Avg > Factor

Select number of
traces to average

16

Channel

Averaging

Avg > Averaging

Enable/disable
averaging

NO (disable averaging)

Channel

TTR500 Series User Manual

89

Default settings

Response options

Parameter / Setting

Location

Description

Default value

Scope

Averaging trigger

Avg > Avg Trigger

Perform <Averaging
factor> sweeps /
1 sweep following
trigger

NO

Channel

Smoothing aperture

Avg > Smoothing
Aperture

Select moving average
of frequency points

1.5

Channel

Trace smoothing

Avg > Enable
Smoothing

Enable/disable trace
smoothing

NO

Channel

IF Bandwidth

Avg > IF Bandwidth

Set intermediate
frequency bandwidth

10 kHz

Channel

Error correction

Cal > Correction

Enable/disable error
correction

NO

Channel

Calibration trigger
source

Cal > More > Cal
Trig Source

Select calibration
trigger source

Internal

Channel

xxx

See Also
Stimulus options
Channel / Trace options
Markers / Analysis options
System options
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Markers/Analysis options
Parameter / Setting

Location

Description

Default value

Scope

Reference marker

Setup > More > Ref
Marker

Select reference
marker

3 GHz

Channel

Peak excursion

Search > Peak >
Peak Excursion

Define peak excursion
to find next peak

3 dB

Channel

Peak polarity

Search > Peak >
Peak Polarity

Select peak polarity

Positive

Channel

Target value

Search > Target >
Target Value

Enter target value

0 dB

Channel

Target transition

Search > Target >
Target Transition

Select transition type

BOTH

Channel

Search range

Search > Search
Range

Define search range

Entire sweep range

Channel

Bandwidth search

Search >
Bandwidth

Enable/disable
bandwidth search

NO (disable bandwidth
search)

Channel

Bandwidth value

Search > More >
Bandwidth Value

Specify loss for
bandwidth search

3 dB

Channel

Notch search

Search > More >
Notch

Enable/disable notch
search

NO (disable notch
search)

Channel

Notch search value

Search > More >
Notch Value

Specify notch search
value

-3 dBm

Channel

Couple traces

Function > Couple

Couple/decouple
traces for marker
action

YES (couple traces)

Channel

Discrete mode

Function > Discrete

Set display mode for
marker to discrete
mode

Discrete

Channel

xxx

See Also
Stimulus options
Channel / Trace options
Response options
System options
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System options
Parameter / Setting

Location

Description

Default value

Scope

Save data

Save / Recall > Save

Save state, calibration,
state data

*.cstate

Analyzer

Recall data

Save / Recall >
Recall

Recall state,
calibration, state data

*.cstate

Analyzer

SnP format

Save / Recall > Save
SnP > SnP Format

Select format for
Touchstone file

Real + Imaginary

Analyzer

Bias Tee

More > Bias Tee

Enable/disable bias tee

Disabled

Analyzer

Reference clock
source

More > Reference
Clock Source

Select internal/external
reference clock

Internal

Analyzer

Beep warning

More > Beep > Beep
Warning

Beep when warning

YES

Analyzer

System correction

More > System
Correction

Enable/disable system
correction

YES (enable system
correction)

Analyzer

Noise floor

More > Simulator >
Noise Floor

Insert additive noise

-150 dBm/Hz

Analyzer

Log severity

More > Log Severity

Control on logging
severity

Warning

Analyzer

OPC logger

More > OPC Logger

Enable/disable OPC
logger

NO disable OPC
logger)

Analyzer

xxx

See Also
Stimulus options
Channel / Trace options
Response options
Markers / Analysis options
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Frequency response of a band pass filter
Suppose you want to measure the frequency response of a band pass filter. This is a 3–part procedure:
Calibrate the VNA
Set up the band pass filter
Measure frequency response

Calibrate the VNA
1. Select a calibration kit. You can use one of the standard kits preloaded in VectorVu-PC or create
a kit of your choice.
2. Calibrate the VNA. For the purpose of this measurement, you perform the 2–port 2–path SOLT
(Full two-port) calibration.

See Also:
Select a calibration kit
Add/Modify a calibration kit
2–port 2–path SOLT (Full Two Port) calibration

Set up the band pass filter
1. Connect the male terminal of the filter to port 1 of the VNA using an adapter cable. You may need to
use a male-male adapter for this purpose.
2. Connect the female terminal of the filter to port 2 of the VNA using an adapter cable.

3. In VectorVu-PC, set these parameters. The values below apply for the band pass filter used in this
example. Select appropriate values based on the characteristics of the filter you use.
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Parameter

Location

Setting

Start frequency

Stimulus > Start

500 MHz

Stop frequency

Stimulus > Stop

2.5 GHz

IF Bandwidth

Response > Avg > IF Bandwidth

100 Hz

Power

Stimulus > Sweep Setup > Power Menu
> Power Level

0 dB

Points

Stimulus > Sweep Setup > Power Menu
> Points

201

xxx

Record S-parameters
1. Set up traces to measure the S-parameters of the filter. In Channel/Trace > Trace > Num Traces,
select 4 traces. The traces are labeled Tr1–Tr4 and they appear in different colors in the active channel.
2. Click on trace Tr1 to make it active. Use this to measure S11.
3. In Response > Measure, click S11. The VNA records the S11 measurement in Tr1.
4. Repeat steps 2 and 3 for the other S-parameters. The active channel displays all 4 traces.
5. To view the traces in separate windows, in Channel / Trace > Trace > Trace Layout, select a
configuration for four traces.
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6. If you need to adjust the scale for any of the traces, use Response > Scale > Auto Scale. Use the Auto
Scale All option to adjust the scales of all of the traces simultaneously.

Bandwidth search
1. Select the S21 trace.
2. In Markers / Analysis > Setup, select Marker 1 and set it to 1.5 GHz.
3. To perform the bandwidth search, select Markers / Analysis > Search > Bandwidth.
4. In Markers / Analysis > Search > More > Bandwidth Value, specify 3 dB.
The VNA displays these bandwidth parameters in the upper left corner of the graph:
Bandwidth
Center frequency
Lower cutoff frequency
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Higher cutoff frequency
Q value
Insertion loss

See Also
Use touchstone SnP files for offline analysis

Use touchstone (SnP) files for offline analysis
In this example, you save and recall S-parameter data for a device using touchstone (SnP) files. When
you save device information in an SnP file, you can use the file to perform analysis offline and away
from the test setup. Also, you do not require the device for analysis as long as the SnP file contains all
the S-parameter information.
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Save an S2P file
1. Calibrate the VNA following the 2–port 1–path SOLT Enhanced Response calibration procedure.
2. Set up four traces (Tr1–Tr4). Measure all four S-parameters.
3. In System > Save / Recall > Save SnP, select S2p.
4. After saving the file, go to the saved location and open the file using a text editor. Observe the
information stored in the file.

Notice that the S-parameters are stored in the complex form in an S2P file. Next, you recall the
S-parameter information stored in this file.

Recall an S2P file
Recall the saved S2P file in the simulator mode in VectorVu-PC to use it offline.
1. Open the Connection Manager in System > More > Connections.
2. Connect VectorVu-PC to the internal simulator.
3. In System > More > Simulator, select Load SnP.
4. Import the S2P file saved in step 3 in Save an S2P file.
5. Verify the S-parameter information contained in the S2P file. In Response > Measure, select any
S-parameter and the graph should populate with the corresponding trace, reading data from the S2P
file you recalled.

See Also
Frequency response of a band pass filter
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How the VNA operates

How the VNA operates
The TTR500 series VNAs operate over frequency ranges of 100 kHz – 3 GHz (TTR503A) and 100 kHz –
6 GHz (TTR506A). The VNA measures RF and microwave electronic components by:
Providing a stimulus signal that is stepped over a range of measurement frequencies.
Receiving these signals:
stimulus signal (r1, r2)
signals reflected from the DUT (a1, a2)
signals transmitted through the DUT (b1, b2)
By sending and receiving these signals, the VNA measures S-parameters that are ratios of the signals.
The reflection measurements (S11, S22) are ratios of the reflected signal to the stimulus signal.
S11=a1/r1
S22=a2/r2
The transmission measurements (S21, S12) are ratios of the signals that pass through the DUT.
S21=b2/r1
S12=b1/r2
This diagram illustrates the internal operation of the VNA and the flow of stimulus and receiver signals.
The RF sources, receivers and logic blocks are integrated in a custom IC chip.
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Directional coupler
Separate signals flow from the directional coupler in the forward and reverse directions. The forward
direction is the direction of signal (r1) flowing out of the VNA port. The reverse direction is the direction
of signal (a1) flowing into the VNA port.

Synthesized RF sources
There are two RF sources in the VNA. Each source is capable of synthesizing signals from 100 kHz to
3 GHz (TTR503A) and 6 GHz (TTR506A). The signals are phase-locked to a 10 MHz reference. You can
generate the reference internally or provide it as an input from an external time-base. The signals from
each RF source feed to the directional coupler. The signals become an output from the measurement port.
This output signal is used as a stimulus for S-parameter measurements.

Receivers
There are 6 receivers in the TTR500 series VNA device. Each receiver can measure the magnitude
and phase of a signal.

Incident receivers (b1, b2)
Each measurement port has a receiver that measures the signal incident to the port.

Reflection receivers (a1, a2)
Each measurement port has a receiver that measures the signals reflected by the DUT.

Reference receivers (r1, r2)
Each measurement port has a reference receiver that measures a sample of the signal output of each port.

Controls/Communication logic
This block controls all the sources and receivers in the VNA. It also enables communication between
the sources and receivers and the USB controller.

Time base
The time base provides a 10 MHz frequency and time reference. The VNA uses the time base to phase
lock all receivers and sources. The time base can be used as an internal or external 10 MHz source.
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USB
The USB 2.0 provides bidirectional communication between the TTR500 series VNA and the host
computer. Use a cable to connect the USB port on the VNA to either a USB 2.0 or a USB 3.0 port on
a computer. The TTR500A VNA uses a USB2 type B connector.

Power supply
The power supply block provides power to all the circuit elements in the VNA. The block requires a
4.75V-5.25V DC supply.

Synchronization and trigger
The VNA has options to set an external or internal trigger. The trigger is used to synchronize measurements
and settings.

Bias tee
The internal bias tee feature allows you to provide a bias to the DUT through the VNA. The bias tee
requires an external voltage source or power supply. Avoid powering the bias tee connectors during
calibration as this can affect calibration standards.

Device information
You can find model and registration information about your VNA in Help > About.
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Every TTR500 unit is defined by the model followed by its serial number and a unique identifier. The
identifier changes:
When you get the unit serviced at Tektronix.
Every time the internal USB drive is programmed.
The device information display also shows the version of VectorVu-PC that is running on your system.
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Software download
Download the most current version of VectorVu-PC at www.tek.com/downloads.

Environmental specifications
Characteristic

Description

Temperature Range
Operating

5 °C to +50 °C

Non-operating

–40 °C to +71 °C

Humidity
Operating (non-condensing)

Temperature Range

Relative Humidity

+10 °C to +30 °C

5% to 80% RH

+30 °C to +40 °C

5% to 75% RH

+40 °C to +50 °C

5% to 45% RH

Altitude
Operating

3000 meters

Non-operating

4600 meters

xxx

Log data
When you use the TTR500 VNA to make measurements, the instrument creates a log file. This content
includes:
Duration that the VNA was powered on
Number of times the VNA was powered on
Results of the power on test
Number of switching times of the internal mechanical relay
Number of times of overload
Event log
To delete this log of data, in the programmatic interface, use SCPI.SERVice.LOGGing.CLEar.
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Recommended calibration kits
Tektronix recommends the usage of these standard calibration kits with the TTR500 series VNA devices.
Calibration kit

Description

Matching adapter

Description

CALMECH-716

7/16 OSLT Mechanical Cal
Kit 0 to 7.5 GHz (SPINNER
BN 53 38 40)

THRU-716-FM

7/16 OSLT Mechanical Cal Kit MF
Thru Option 0 to 7.5 GHz (SPINNER
BN 756301R000)

CALMECH-N

type-N OSLT Mechanical Cal
Kit 0 to 18 GHz (SPINNER
BN 53 38 61)

THRU-N-FM

type-N OSLT Mechanical Cal Kit MF
Thru Option 0 to 18 GHz (SPINNER
BN 533918R000)

CALMECH35MM

35mm OSLT Mechanical Cal
Kit 0 to 32 GHz ( Spinner BN
53 38 54)

THRU-35MM-FM

35mm OSLT Mechanical Cal Kit MF
Thru Option 0 to 32 GHz ( Spinner BN
533769R000)

CALSOLTNF

Calibration kit, 4-in-1
type-N (f) short, open,
load, through, 9 GHz

CALSOLTNM

Calibration kit, 4-in-1
type-N(m) short, open,
load, through, 9 GHz

CALSOLT35F

Calibration kit, 4-in-1
3.5 mm (f) short, open,
load, through, 13 GHz

CALSOLT35M

Calibration kit, 4-in-1 3.5 mm
(m) short, open, load,
through, 13 GHz

CALSOLT716F

Calibration kit, 4-in-1 7/16 (f)
short, open, load, through,
6 GHz

CALSOLT716M

Calibration kit, 4-in-1 7/16 (m)
short, open, load, through,
6 GHz

CALSOLTNF-75

Calibration kit, 4-in-1 type-N(f)
short, open, load, through, 75
Ω, 3 GHz

CALSOLTNM-75

Calibration kit, 4-in-1
type-N(m) short, open,
load, through, 75 Ω, 3 GHz

xxx
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Measurement accessories
These accessories are available for use with the TTR500 series VNA instruments. Contact your local
Tektronix office or order online at www.tek.com. Specify the part number for the accessory you need.
Product

Tektronix part number

Description

Rack mount kit

TTR500RACK

Rack mount kit for TTR500 series VNA.
Holds up to two TTR500 series instruments.

Transit case

TTR500TRANSIT

Transit case for TTR500 series VNA.

Demo kit

TTR500-DEMO-KIT

Demo kit for TTR500 VNAs (case,
calibration kit, filter, two cables).

xxx

Attenuators and bias tee
Tektronix part number

Description

011022200

Attenuator, fixed, 10 dB,2 W,DC-18 GHz, type-N(F) to type-N(F)

011022300

Attenuator, fixed; 10 dB,2 W,DC-18 GHz, type-N(M) to type-N(F)

011022400

Attenuator, fixed; 10 dB,2 W,DC-18 GHz, type-N(M) to type-N(M)

011022500

Attenuator, fixed; 40 dB,100 W,DC-6 GHz, type-N(M) to type-N(F)

011022600

Attenuator, fixed; 40 dB,50 W,DC-18 GHz,1.3 VSWR TYP;type-N(M) to type-N(F)

011022700

Bias tee, type N(M) RF, type N(F) RF+DC, BNC(F) BIAS, 1 W, 0.5 A, 2.5 MHz-6 GHz

011022800

Attenuator, fixed; 3 DB,2 W,DC-18 GHZ, type-N(M) to type-N(F)

xxx

Cables
Tektronix part number

Description

012174500

Cable, rugged, phase-stable, type-N(M) to type-N(F), 5ft or 1.5m

012174600

Cable, rugged, phase-stable, type-N(M) to type-N(F), 3.28ft or 1m

012174700

Cable, rugged, phase-stable, type-N(M) to 7/16(F), 60 cm

012174800

Cable, rugged, phase-stable, type-N(M) to 7/16(F), 3.28ft or 1m

012174900

Cable, rugged, phase-stable, type-N(M) to 7/16(F), 5ft or 1.5m

012175000

Cable, rugged, phase-stable, type-N(M) to 7/16(M), 3.28ft or 1m

012175100

Cable, rugged, phase-stable, type-N(M) to 7/16(M), 5ft or 1.5m

012175200

Cable, rugged, phase-stable, type-N(M) to 7/16(M), 60 cm

012175300

Cable, rugged, phase-stable, type-N(M) to DIN 9.5(F), 60 cm

012175400

Cable, rugged, phase-stable, type-N(M) to DIN 9.5(F), 3.28ft or 1m

012175500

Cable, rugged, phase-stable, type-N(M) to DIN 9.5(F), 5ft or 1.5m

012175600

Cable, rugged, phase-stable, type-N(M) to DIN 9.5(M), 3.28ft or 1m
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Tektronix part number

Description

012175700

Cable, rugged, phase-stable, type-N(M) to DIN 9.5(M), 5ft or 1.5m

012175800

Cable, rugged, phase-stable, type-N(M) to DIN 9.5(M), 60 cm

012175900

Cable, rugged, phase-stable, type-N(M) to TNC(F), 3.28ft or 1m

012176000

Cable, rugged, phase-stable, type-N(M) to TNC(F), 5ft or 1.5m

012176100

Cable, rugged, phase-stable, type-N(M) to TNC(F), 60 cm

012176200

Cable, rugged, phase-stable, type-N(M) to TNC(M), 60 cm

012176300

Cable, rugged, phase-stable, type-N(M) to TNC(M), 3.28ft or 1m

012176400

Cable, rugged, phase-stable, type-N(M) to TNC(M), 5ft or 1.5m

012176500

Cable, rugged, phase-stable, type-N(M) to type-N(F), 60cm

012176600

Cable, rugged, phase-stable, type-N(M) to type-N(F), 3.28ft or 1m

012176700

Cable, rugged, phase-stable, type-N(M) to type-N(M), 3.28ft or 1m

012176800

Cable, rugged, phase-stable, type-N(M) to type-N(M), 60 cm

012176900

Cable, rugged, phase-stable, type-N(M) to type-SMA(F), 60 cm

012177000

Cable, rugged, phase-stable, type-N(M) to type-SMA(F), 3.28ft or 1m

012177100

Cable, rugged, phase-stable, type-N(M) to type-SMA(F), 5ft or 1.5m

012177200

Cable, rugged, phase-stable, type-N(M) to type-SMA(M), 60 cm

012177300

Cable, rugged, phase-stable, type-N(M) to type-SMA(M), 3.28ft or 1m

012177400

Cable, rugged, phase-stable, type-N(M) to type-SMA(M), 5ft or 1.5m

xxx
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Tektronix part number

Description

013040200

Adapter, coaxial, 50 Ωtype-N (M) to type 7/16(M), 7.5 GHz

013040300

Connector, adapter, coaxial, 50 Ω type-N(M) to type DIN 4.1/9.5(M), 11 GHz, VSWR 1.2

013040400

Adapter, coaxial, 50 Ω type-N(M) to type-7/16 (F) 6GHz

013040500

Connector, adapter, coaxial, 50 Ω type-N(M) to type-DIN 4.1/9.5(F),11 GHz,VSWR 1.2

013040600

Adapter, coaxial, 50 Ω type-N(M) to type-SMA(F), 18 GHz

013040700

Adapter, coaxial, 50 Ω type-N(M) to type-SMA(M),18 GHz

013040800

Adapter, coaxial, 50 Ω type-N(M) to type-TNC(F), 18 GHz

013040900

Adapter, coaxial, 50 Ω type-N(M) to type-TNC(M), 18 GHz

013041100

Coaxial adapter, 50 Ω type-N (M) to type-N (F) 18 GHz

013041300

Coaxial adapter, MIN loss impedance matching PAD,type-N(M) 50 Ω to type-BNC(M) 75 Ω,
3 GHz, 1.35 MAX VSWR, 5.7+/-0.5dB INS loss

013041500

PAD, 50/75 Ω, minimum loss, type-N(M) 50 Ω to type-F(M) 75 Ω

013042200

Coaxial adapter, MIN loss impedance matching PAD, 50 Ω N(M) to 75 Ω BNC(F),
1.35 VSWR MAX, 5.7+/-0.5dB INS loss, 3 GHz

015078700

PAD, 50/75 Ω, minimum loss, type-N(M) 50 Ω to type-F(F) 75 Ω
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Tektronix part number

Description

015078800

PAD, 50/75 Ω, minimum loss, type-N(M) 50 Ω to type-N(F) 75 Ω

020316600

MFG ASSY; tracking generator and GPS demo kit

119873300

Antenna; active,GPS & glonass, magnetic mount, 5M Cable, 3V, 8MA TYP, SMA Conn,
RG-174 Cable

xxx

Accessory cables
Tektronix part number

Description

012173800

Cable ASSY; coaxial, RFD, 50 Ω, 40 inch, N-type, both ends, male

012048200

Cable Assembly, RF; coaxial; RFD, 50 Ω, (175-1455-00), 36 inch L, BNC male to BNC
male, strain relief boots

013041000

Adapter, coaxial, 50 Ω type-N(F) to type-N(F) 18 GHz

013041200

Adapter, coaxial, 50 Ω, type-N(M) to type-N(M), 18 GHz

xxx

Calibration kits
Tektronix part number

Description

CALMECH-716

7/16 OSLT mechanical calibration kit 0 to 7.5 GHz (SPINNER BN 53 38 40)

CALMECH-N

Type-N OSLT mechanical calibration kit 0 to 18 GHz (SPINNER BN 53 38 61)

CALMECH-35MM

35mm OSLT mechanical calibration kit 0 to 32 GHz ( Spinner BN 53 38 54)

THRU-716-FM

7/16 OSLT mechanical calibration kit MF Thru Option 0 to 7.5 GHz (SPINNER BN
756301R000)

THRU-N-FM

type-N OSLT mechanical calibration kit MF Thru Option 0 to 18 GHz (SPINNER BN
533918R000)

THRU-35MM-FM

35mm OSLT mechanical calibration kit MF Thru Option 0 to 32 GHz (Spinner BN 533769R000)

CALSOLTNF

Calibration kit, 4-in-1 type-N (f) short, open, load, through, 9 GHz

CALSOLTNM

Calibration kit, 4-in-1 type-N (m) short, open, load, through, 9 GHz

CALSOLT35F

Calibration kit, 4-in-1 3.5 mm (f) short, open, load, through, 13 GHz

CALSOLT35M

Calibration kit, 4-in-1 3.5 mm (m) short, open, load, through, 13 GHz

CALSOLT716F

Calibration kit, 4-in-1 7/16 (f) short, open, load, through, 6 GHz

CALSOLT716M

Calibration kit, 4-in-1 7/16 (m) short, open, load, through, 6 GHz

CALSOLTNF-75

Calibration kit, 4-in-1 type-N (f) short, open, load, through, 75 Ω, 3 GHz

CALSOLTNM-75

Calibration kit, 4-in-1 type-N (m) short, open, load, through, 75 Ω, 3 GHz

xxx
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Standard Functions
Use standard Windows applications to perform these operations:
Screen capture of images
Print screen – trace or channel display
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Maintain your VNA
To obtain the best performance from your VNA, follow these recommendations when using the
TTR500 instrument:
Calibrate the instrument annually.
Format the internal USB flash memory at least once every year. Refer to instructions in the security
and declassification manual.
In the event of any damage to the instrument, contact the service department at Tektronix so that an
authorized service professional can repair the instrument.

Clean the VNA
When necessary, clean the exterior surface of the instrument with a dry, lint-free cloth or a soft-bristle
brush. If any dirt remains, use a cloth or swab dipped in a 75% isopropyl alchohol solution.
Use a swab to clean narrow spaces around controls and connectors.
Do not use abrasive compounds on any part of the instrument.
Do not use chemical cleaning agents as they can damage the chassis.
Avoid chemicals that contain benzene, toluene, xylene, acetone, or similar solvents.
CAUTION. Avoid getting moisture inside the instrument when cleaning the exterior; use just enough
moisture to dampen the cloth or swab. Use only deionized or distilled water when cleaning. Use a 75%
isopropyl alchohol as a cleanser and rinse with deionized or distilled water.

Return the VNA
In case you need to return the VNA to Tektronix:
Back up any calibration data stored on the VNA.
When repacking the instrument for shipping, use the original packaging. If the packaging is
unavailable or unfit for use, contact your local Tektronix representative to obtain new packaging.
Seal the shipping carton with an industrial stapler or strapping tape.
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Troubleshoot the VNA
If the VNA displays unexpected or erratic behavior, try these corrections:
Behavior

Recommended action

The VNA does not start.

Check to see if the VNA is connected to a DC power source.
If the LED light does not function, contact the service department.

The LED light does not turn
green.

Disconnect the instrument for a few minutes. Reconnect and open VectorVu-PC.

The measurement value is
abnormal.

Check the connection cables, DUT, and all other connections.
Repeat the calibration procedure to obtain the correct error correction factor.
Check the selection and definition of the calibration kit.

VectorVu-PC stalls or crashes
during an operation.

Disconnect the VNA. Reconnect after a couple of minutes and open VectorVu-PC.

An error or warning appears in
the instrument status bar.

Look up the message and its description in IEEE error messages and VNA error
messages.

xxx

IEEE error messages
This is a list of IEEE standard error messages that display in the Instrument Status bar to indicate an
improper setting or incorrect action.
Error ID

Message

Description

100

Command syntax error.

SCPI command error.

101

Invalid character.

Command contains an invalid character.

103

Invalid separator.

Delimiter expected, different character sent.

104

Data type error.

A wrong data element type was received.

105

Parameter not allowed.

Number of parameters exceeds command syntax.

106

Missing parameter.

Number of parameters is less than command syntax.

107

Command not supported.

The command has a valid SCPI syntax but not supported
by the instrument.

108

Header suffix out of range.

The unit of the header is out of range.

110

Numeric data error.

Numeric parameter has invalid syntax.

111

Invalid character in number.

A character is invalid in a numeric parameter - e.g. letter
found in a decimal value.

112

Exponent too large.

Absolute value of the exponent exceeds 32,000.

113

Too many digits.

More than 255 digits in a number.

114

Numeric data not allowed.

A numeric data element was received at an invalid
position.
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120

Invalid suffix.

Suffix has invalid syntax or value.

121

Suffix too long.

Unit has more than 11 characters.

122

Suffix not allowed.

A suffix is attached to a numeric value which does not
have units.

130

Invalid character data.

An invalid character was found in a character data
element.

131

Character data not allowed.

A character data element was received at an invalid
position.

140

String data error.

The content of the string has syntax error.

141

Invalid string data.

The character string is invalid.

142

String data not allowed.

A character string data element was received at an
invalid position.

143

String too long.

String longer than 255 characters.

150

Invalid block data.

The block data is invalid, possibly due to block data
length mismatch.

160

Expression error.

Expression syntax error.

161

Invalid expression.

The expression data element is invalid.

162

Expression data not allowed.

An expression data element was received at an invalid
position.

200

Execution error.

Error in execution.

201

Measurement in progress - init ignored.

Init command received while measurement is in
progress. Init command is ignored.

210

Parameter error.

General parameter error.

211

Unexpected trigger - ignored.

A trigger is detected when not in "waiting for trigger"
state.

212

Data out of range.

Data element out of range was received.

214

Illegal parameter value.

Measurement parameter is invalid - e.g. the source or
receive port are invalid.

220

File not found.

Specified file not found.

221

File name error.

File name syntax error.

301

Error queue overflow.

An error occurred when there is only one slot available
in the error queue.

401

Query interrupted.

Data bytes are received before a response of a previous
query.

402

Query unterminated.

Instrument is designated as the talker and an incomplete
program message is received.

403

Query deadlocked.

Both input and output buffers are full.

404

Query unterminated after indefinite
response.

Query asking for indefinite response is followed by a
new query.

500

Data array contains NAN values.

Data array sent to user contains NAN values.

xxx
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VNA error messages
This is a list of instrument-specific error messages that display in the Instrument Status bar to indicate an
improper setting or incorrect action.
Error ID

Message

Description

10

Unable to calculate calibration data. Missing
standards.

Some standards were not measured for the selected
calibration method.

11

Duplicate port numbers.

Identical port numbers specified in a list of ports.

12

No calibration method selected.

Unable to save calibration data before selecting a
calibration method.

13

Specified error term is invalid for the selected
calibration method.

This error term is not applicable for the selected
calibration method.

14

Normal calibration not allowed in frequency offset
mode.

Unable to execute normal calibration in frequency
offset mode.

15

Scalar mixer calibration not allowed when frequency
offset mode is disabled.

Scalar mixer calibration not allowed when frequency
offset mode is disabled.

16

Unable to perform partial override. No calibration
method specified.

Unable to perform partial override when the calibration
method is not specified.

17

Correction not enabled. No calibration data exists.

Error correction cannot be enabled because no
calibration data exists.

20

eCal module does not support specified number
of ports.

Unable to run multi-port calibration. eCal module has
insufficient number of ports.

21

eCal failure.

Unable to configure or read from eCal module.

22

eCal not connected in RF path

eCal auto-detect does not recognize RF connectivity
between the VNA and the eCal module

23

Unable to perform confidence check for mixed
mode S-parameters.

Unable to perform confidence check for mixed mode
S-parameters.

24

Characterization not found in eCal module.

Characterization entry does not exist in eCal module
memory.

30

Target value not found.

Target value not found within the specified excursion
in target search.

31

Peak not found.

Peak not found within the specified excursion in peak
search.

40

Selected channel not on display.

Selected active channel is not on display.

41

Selected trace does not exist.

Selected active trace does not exist.

42

No valid memory trace.

Unable to perform memory operation where there is
no valid memory trace.

43

Time domain processing not supported in frequency
offset mode.

Unable to perform time domain transform or gating
in frequency offset mode.
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Error ID

Message

Description

44

Fixture simulator not allowed in frequency offset
mode.

Unable to run fixture simulator in frequency offset
mode.

45

Auto port extension not allowed in power sweep or
frequency offset mode.

Auto port extension not allowed in power sweep or
frequency offset mode.

46

No valid measurement to save in file.

Unable to save trace data. No valid trace available.

50

Frequency out of range.

Selected frequency outside instrument range.

60

Power meter not found.

Unable to locate power meter based on specified
VISA resource name.

61

Power meter not stable.

Power meter reading exceeds tolerance or fails to
stabilize within predefined time.

62

Signal generator not found.

Unable to locate signal generator based on specified
VISA resource name.

63

Unable to control external signal generator.

Unable to control external signal generator.

64

Unable to communicate with power meter.

Unable to communicate with power meter.

65

Power meter already claimed.

Power meter already claimed by another application.

66

Selected power sensor does not support the
configured sweep range.

Selected power sensor does not support the
configured sweep range. Unable to perform power
calibration.

100

Load failed.

Load from file failed.

101

Save failed.

Save to file failed.

102

THRU standard should be defined with S2P file.

THRU standard should be defined with S2P file.

103

Standard should be defined with S1P file.

Standard should be defined with S1P file.

104

Factory calibration not found.

Unable to locate factory calibration zip file for this
instrument. Default calibration used instead.

200

Option not installed.

Unable to perform optional function. This option is not
installed in the instrument.

210

PLL not locked.

Measurement data is not valid. At least one frequency
point resulted in an unlocked PLL.

220

Power trip event. RF turned off.

Power received was too high. Source turned off to
prevent damage to VNA.

230

Self test failure.

Instrument self test failed.

300

Unable to estimate adapter length in zero span.

Unable to estimate adapter length in zero span.

400

Invalid equation expression

Invalid equation is specified in the equation editor

401

Invalid equation label

Invalid equation label.

500

Instrument disconnected

The instrument has been disconnected.

501

Instrument is not connected.

Unable to connect to instrument that is not connected
to host.

502

Instrument connection failed.

Instrument connection failed.
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Error ID

Message

Description

503A

Instrument connection failed.

Instrument already claimed.

504

Instrument connection failed.

Instrument not activated.

505

Instrument connection failed.

Device is not connected to USB.

506A

USB Storage set state failure.

Unable to set state of USB Storage.

507

USB Storage get state failure.

Unable to get state of USB Storage.

508

Instrument activation failed.

Instrument already claimed.

509

Instrument activation failed.

Instrument already activated.

510

Instrument activation failed.

Device is not connected to USB.

511

Instrument temperature has exceeded safe
operating range.

The temperature of the TTR500 unit has exceeded
safe operating range. VectorVu-PC has switched to
offline mode.

601

Unable to load power meter DLL.

Unable to load power meter DLL. Verify DLL is
installed and in execution path.

602

Incompatible power meter DLL.

Power meter installation is not compatible with this
application.

603

Power meter initialization failed.

Power meter initialization failed.

604

Power meter measurement failed.

Power meter measurement failed.

700

Insufficient memory for current sweep settings.
Unable to start sweep recording.

Insufficient memory for current sweep settings.
Unable to start sweep recording.

1000

Calibration interpolated.

Measurement and calibration stimulus points are not
identical. Calibration data was interpolated.

1001

Measurement conditions not identical to calibration
conditions.

Measurement and calibration conditions are not
identical. Error correction can be inaccurate.

1002

Change in global power or IFBW. Segment table
updated accordingly.

Global power or IFBW has changed. The per-segment
power / IFBW were overridden in the segment table.

xxx
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Warnings and notifications

Warnings and notifications
This is a list of warning messages and notifications that display in the Instrument Status bar.

Warnings
Warning ID

Message

Description

1000

Calibration interpolated

Measurement and calibration stimulus points are
not identical. Calibration data was interpolated

1001

Measurement conditions not identical to
calibration

Measurement and calibration conditions (e.g.
power, IF BW) are not identical. Error correction
might not be accurate

1002

Changed global power or IF BW - updated
segment table accordingly

Global power or IF BW changed - the per-segment
power / IF BW were overridden in the segment table

xxx

Notifications
Notification
ID

Message

Description

2000

Instrument connected

A TTR500 unit has been connected.

xxx
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